Bug 147762 - /proc/cpuinfo "physical id" (phys_proc_id[]?) corrupt.
/proc/cpuinfo "physical id" (phys_proc_id[]?) corrupt.
Status: CLOSED DUPLICATE of bug 147674
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 19:51 EST by Scott McClung
Modified: 2013-08-05 21:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 16:45:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott McClung 2005-02-10 19:51:10 EST
Description of problem:

/proc/cpuinfo 'physical id' becomes corrupt, displaying arbitrary numbers.

Version-Release number of selected component (if applicable):

kernel 2.4.9-e59

How reproducible:

Bug only appears under memory pressure and/or high load.  

Steps to Reproduce:
  
In every case so far, just running the standard database load
procedures will trigger this.

Actual results:

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) MP CPU 3.00GHz
stepping        : 6
cpu MHz         : 2972.184
cache size      : 512 KB
physical id     : -17034351
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov 
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss tm
bogomips        : 5924.45

[snip, similar results for other 3 CPUs]

Expected results:

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) MP CPU 3.00GHz
stepping        : 6
cpu MHz         : 2972.184
cache size      : 512 KB
physical id     : 0
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov 
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss tm
bogomips        : 5924.45

[snip]

Additional info:

Is this possibly the result of phys_proc_id[] being declared as
__initdata, getting freed as we start to swap, and on subsequent runs
of get_cpuinfo() for procfs, showing a corrupt value?  I mention it
because it's not labeled as __initdata in the mainline 2.6.x sources,
and it seems a plausible explanation.

Note that this machine is a 4-way SMP with HT off (noht at boot).
Comment 1 Scott McClung 2005-02-11 10:47:28 EST
This is a duplicate of 147674.

Note You need to log in before you can comment on or make changes to this bug.