Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1477632 - Remove the need for a stepped upgrade between 3.5 to 3.6 with HE and RHEV-H
Remove the need for a stepped upgrade between 3.5 to 3.6 with HE and RHEV-H
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.10
Unspecified Unspecified
high Severity high
: ovirt-3.6.z-async
: ---
Assigned To: Ido Rosenzwig
Nikolai Sednev
: Triaged, ZStream
: 1489925 1503446 (view as bug list)
Depends On:
Blocks: 1488891 1489925 1503445 1503446 1529957
  Show dependency treegraph
 
Reported: 2017-08-02 09:52 EDT by Yaniv Lavi
Modified: 2018-02-07 09:10 EST (History)
19 users (show)

See Also:
Fixed In Version: ovirt-engine-3.6.12.3
Doc Type: Enhancement
Doc Text:
Upgrading a Red Hat Enterprise Virtualization 3.5 self-hosted engine environment, running on RHEL 6 or RHEV-H 6 hosts, to Red Hat Enterprise Virtualization 3.6, running on Next Generation RHVH or RHEL 7 hosts, has been greatly simplified
Story Points: ---
Clone Of:
: 1503446 (view as bug list)
Environment:
Last Closed: 2018-02-07 09:10:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 83440 None None None 2017-11-27 02:40 EST
oVirt gerrit 83614 ovirt-engine-3.6 MERGED packaging: bin: Tool to help upgrade 3.5/el6 hosted-engine hosts directly to 3.6/el7 2017-11-27 05:33 EST
oVirt gerrit 84856 ovirt-engine-3.6 MERGED packaging: bin: host-direct-upgrade fix 2017-11-29 10:00 EST
Red Hat Product Errata RHEA-2018:0284 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.12 2018-02-07 14:31:42 EST

  None (edit)
Description Yaniv Lavi 2017-08-02 09:52:18 EDT
Description of problem:
We currently recommend a stepped upgrade from 3.5 to 3.6 for HE.
As we now support 3.6 NGN for upgrade flow and CLI is supported on this hypervisor, CEE would like to have a simpler upgrade method that will not require a stepped upgrade.
I suggest providing steps to copy existing answer file from RHEV-H el6 3.5 to next generation RHV-H el7 3.6 and change the answer to make the setup think it is an upgrade.

Can you provide steps for this? 

Version-Release number of selected component (if applicable):
3.6.z

How reproducible:
100%

Steps to Reproduce:
1. Upgrade RHV 3.5 to 3.6 with HE and RHEV-H/RHEL-H el6.
2. 
3.

Actual results:
You need to step the HE cluster upgrade with RHEV-H 3.5 el7.

Expected results:
Reinstall to next generation RHV-H 3.6 el7 or RHEL-H 3.6 el7 directly and have steps to trigger upgrade of HE.

Additional info:
Comment 1 Marina 2017-08-14 10:31:46 EDT
Summary:
skipping 3.5 el6 -> 3.5 el7 -> 3.6 el7 ->3.6 el7 ngn 
going    3.5 el6 -> 3.6 el7 ngn


Just remember, the main reason for this 3.5 el7 -> 3.6 el7 was to trigger autoimport of HE SD, as per this solution:
https://access.redhat.com/solutions/2351141
Comment 2 Yaniv Lavi 2017-08-28 05:44:46 EDT
Any updates?
Comment 3 Simone Tiraboschi 2017-09-27 14:13:09 EDT
(In reply to Yaniv Lavi (Dary) from comment #2)
> Any updates?

https://docs.google.com/document/d/1aly0DoaKf1API1jIWY4p8Rwax9CLTMokXBWM9hQt2RY/edit#heading=h.dn56zw88plel

Maybe we could ship an helper script or a set of ansible playbooks to make it even easier.
Comment 4 Douglas Schilling Landgraf 2017-10-17 11:37:44 EDT
*** Bug 1489925 has been marked as a duplicate of this bug. ***
Comment 5 Yaniv Lavi 2017-10-18 04:48:24 EDT
This helper script need to be updated in the KBase, but doesn't require a backport to 3.6.z codebase.
Comment 6 Yaniv Lavi 2017-10-18 04:49:58 EDT
(In reply to Yaniv Lavi (Dary) from comment #5)
Correction:
> This helper script for this process needs to be updated in the documentation and should be included in the 3.6.z code base.
Comment 7 RHV Bugzilla Automation and Verification Bot 2017-12-31 06:42:12 EST
*** Bug 1503446 has been marked as a duplicate of this bug. ***
Comment 18 Nikolai Sednev 2018-02-07 08:05:40 EST
Worked for me with RHVH-3.6-20180130.0-RHVH-x86_64-dvd1.iso.
I've followed the https://access.redhat.com/documentation/en-us/red_hat_enterprise_virtualization/3.6/html-single/self-hosted_engine_guide/index#Upgrading_a_RHEL7_Self-Hosted_Engine section 6.3 for upgrading from 3.5 pair of RHEL6.9 to PAir of 3.6RHEVH NGNs.
Comment 21 errata-xmlrpc 2018-02-07 09:10:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0284

Note You need to log in before you can comment on or make changes to this bug.