Bug 147764 - 5% of home partition capacity is wasted
5% of home partition capacity is wasted
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 20:27 EST by Amadeus
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-24 14:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amadeus 2005-02-10 20:27:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
When a home partition is made from Disk Druid the -m switch is not changed to '0', which means that 5% of the home partition capacity is lost. I.e. on a 100GB patition you only get a 95GB partition.

These 5% is reserved to root, which gives good sence on / but not on /home.

This can be fixed after installtion by unmounting the partition and writing
tune2fs -m 0 /dev/hdaX

But I doubt many know this=(

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC and let Disk Druid partition the disk.
2.
3.
  

Additional info:
Comment 1 Amadeus 2005-03-01 16:19:41 EST
An easy hack would be to run
tune2fs -m 0 /dev/hdaX

(as described above) at the first boot after the installation.

But I think a nicer solution would be to make Disk Druid do it on all partitions
that is not going to mounted as /

Comment 2 Matthew Miller 2005-04-24 12:59:07 EDT
I think letting people run tune2fs if they want to is a good choice, because
ext2/ext3 performance suffers severely if your partition is very close to full.
Generally, better to reserve that space as an area for the kernel to use to keep
the system operating optimally than to squeeze out every last megabyte,
especially with disk getting so cheap.
Comment 3 Amadeus 2005-04-24 13:07:22 EDT
My point is that, the OS will never need extra space on /home and the space is
thereby wasted.

It may (or may not?) make sence to take 5% on /, but taken in cosideration that
it is a desktop computer we are dealing with, these 5% will never be used.

On a server 5% makes sense, as log files etc. can take up a great deal of space.

About your point with the cheap harddiscs, 5% of 200GB is 10GB, which is a lot
of space to loose.
Comment 4 Matthew Miller 2005-04-24 13:35:22 EDT
> My point is that, the OS will never need extra space on /home and the space is
> thereby wasted.

But did you read my comment? The OS *does* need the extra space.


> About your point with the cheap harddiscs, 5% of 200GB is 10GB, which is a lot
> of space to loose.

Only about 5%.
Comment 5 Amadeus 2005-04-24 14:03:12 EDT
Yes, I did read your comment about the OS, but perhaps I have misunderstood it?

From my understanding the kernel does not write to /home, and if you have / on
hda2 and /home on hda3 these 10GB is wasted on hda3.

About your connent on ext2/ext3 preformance, I think 10GB is way off. As
harddiscs sizes increases the waisted space increases.

Wouldn't 10MB be enough?

I think 10GB is a significant amount of space. If any application toke 10GB of
your harddrive, then there would be filed a critical bug for this.

Comment 6 Matthew Miller 2005-04-24 14:14:46 EDT
All writes to disk go through the kernel -- it's part of the kernel's job. As I
understand it, the efficiency issues with ext2/3 (and many filesystems in
general) are directly related to percentage of space free, not just having a few
megabytes around. (This is what makes it so you don't have to run "defrag" on
your Linux filesystems, for example.)

Maybe someone who knows more about this can say otherwise, but that's my
understanding. If you want, try some performance tests (bonnie++, say) on
relatively empty disks and 99% full ones -- filled up in a "natural" way with a
mix of large and small files written in arbitrary order. If you can demonstrate
that the change wouldn't be a performance issue, I'd be all for it.
Comment 7 Amadeus 2005-04-25 18:06:52 EDT
Why is it marked WONTFIX?

Just so I don't waist my time investigating the ext2/ext3 performance.


Note You need to log in before you can comment on or make changes to this bug.