Bug 1477650 - "openstack undercloud install" does not fail when undercloud.conf file is missing. This should fail immediately if the configuration file is not present.
"openstack undercloud install" does not fail when undercloud.conf file is mis...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
medium Severity medium
: beta
: 12.0 (Pike)
Assigned To: Alex Schultz
Arik Chernetsky
: Triaged
Depends On:
Blocks: 1489585
  Show dependency treegraph
 
Reported: 2017-08-02 10:35 EDT by mlammon
Modified: 2017-12-13 16:48 EST (History)
6 users (show)

See Also:
Fixed In Version: instack-undercloud-7.2.1-0.20170821194210.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:48:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1709177 None None None 2017-08-07 16:36 EDT
OpenStack gerrit 491601 None None None 2017-08-23 10:46 EDT
RDO 8358 None None None 2017-08-09 14:15 EDT

  None (edit)
Description mlammon 2017-08-02 10:35:28 EDT
Description of problem:
"openstack undercloud install" does not fail when undercloud.conf file is missing.
This should fail immediately if the configuration file is not present.

In addition, it should test the "local_interface" variable for its existence before continuing to allow the program to check.

Environment:
instack-6.0.1-0.20170706195330.ec102b1.el7ost.noarch
instack-undercloud-7.1.1-0.20170714211622.el7ost.noarch

How reproducible?
100%

Steps to Reproduce:
1. Install undercloud without undercloud.conf

2.
3.

Actual results:
It will fail about three minutes into the install and there are various erroneous errors. 

Expected results:
Error that configuration file is missing and quit immediately.

Additional info:
Comment 6 mlammon 2017-09-07 16:00:50 EDT
The verification of this bug has complete.  It will properly fail undercloud installation if the local_interface assignment is not valid.   However, it did kick out a traceback error.  A new RFE was filed to clean up tracebacks in future release.

[RFE] cleanup tracebacks: validation with local_interface existence within undercloud.conf file works but with tracebacks
https://bugzilla.redhat.com/show_bug.cgi?id=1489585
Comment 10 errata-xmlrpc 2017-12-13 16:48:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.