Bug 1477659 - Service request detail display fails with exception page
Service request detail display fails with exception page
Status: CLOSED DUPLICATE of bug 1474504
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: cfme-future
Assigned To: Aparna Karve
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 10:55 EDT by Jeff Warnica
Modified: 2017-12-05 10:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 16:40:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)
production.log (37.82 KB, text/plain)
2017-08-02 10:55 EDT, Jeff Warnica
no flags Details

  None (edit)
Description Jeff Warnica 2017-08-02 10:55:53 EDT
Created attachment 1308289 [details]
production.log

Description of problem:
Per summary, attempting to display a completed service request details page triggers a CF screen of death.

Version-Release number of selected component (if applicable):


How reproducible:
For a particular Service request, always.

Steps to Reproduce:
1. navigate to Service->Request, click through to service

Actual results:
CF screen of death.

Expected results:
Service Request details



Attached is the production.log from the UI box, and below is what I get from REST as to what the request looked like:


[ec2-user@cloudforms02 vmdb]$ curl -u admin:smartvm -k https://localhost/api/requests/10000000000003|python -m json.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1567    0  1567    0     0   7997      0 --:--:-- --:--:-- --:--:--  8035
{
    "actions": [
        {
            "href": "https://localhost/api/requests/10000000000003",
            "method": "post",
            "name": "edit"
        },
        {
            "href": "https://localhost/api/requests/10000000000003",
            "method": "post",
            "name": "approve"
        },
        {
            "href": "https://localhost/api/requests/10000000000003",
            "method": "post",
            "name": "deny"
        }
    ],
    "approval_state": "approved",
    "created_on": "2017-08-02T14:20:28Z",
    "description": "Provisioning Service [CentOS 6] from [CentOS 6]",
    "fulfilled_on": "2017-08-02T14:24:39Z",
    "href": "https://localhost/api/requests/10000000000003",
    "id": 10000000000003,
    "message": "[DB/UI] Service [CentOS 6-20170802-102058] Provisioned Successfully",
    "options": {
        "cart_state": "ordered",
        "delivered_on": "2017-08-02T14:20:42.993Z",
        "dialog": {
            "Array::dialog_dialog_0_environment": "Classification::10000000000021",
            "dialog_dialog_0_count": 1,
            "dialog_dialog_0_flavor": "10000000000001",
            "dialog_dialog_0_service_name": "RHC Service 1 DELETE ME",
            "dialog_dialog_0_service_type": "dev",
            "dialog_dialog_0_vm_prefix": "DELETEME"
        },
        "requester_group": "EvmGroup-super_administrator",
        "src_id": 10000000000001,
        "user_message": "[DB/UI] Service [CentOS 6-20170802-102058] Provisioned Successfully",
        "workflow_settings": {
            "dialog_id": 10000000000002,
            "resource_action_id": 10000000000139
        }
    },
    "process": true,
    "request_state": "finished",
    "request_type": "clone_to_service",
    "requester_id": 10000000000001,
    "requester_name": "Administrator",
    "service_order_id": 10000000000001,
    "source_id": 10000000000001,
    "source_type": "ServiceTemplate",
    "status": "Ok",
    "tenant_id": 10000000000001,
    "type": "ServiceTemplateProvisionRequest",
    "updated_on": "2017-08-02T14:24:39Z",
    "userid": "admin"
}
Comment 2 Dave Johnson 2017-08-03 19:50:36 EDT
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set it to Low/Low.
Comment 7 Jeff Warnica 2017-08-21 16:40:30 EDT

*** This bug has been marked as a duplicate of bug 1474504 ***

Note You need to log in before you can comment on or make changes to this bug.