Bug 1477728 - Upgrade to Sat 5.8 caused url change in kickstarts, have to edit and republish by hand to correct url. [NEEDINFO]
Upgrade to Sat 5.8 caused url change in kickstarts, have to edit and republis...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
580
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Jiří Dostál
Patrik Segedy
: Regression
Depends On:
Blocks: sat58-errata 1500741
  Show dependency treegraph
 
Reported: 2017-08-02 14:00 EDT by Amy Farley
Modified: 2017-10-19 07:57 EDT (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-java-2.5.14-100-sat
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1500741 (view as bug list)
Environment:
Last Closed: 2017-10-19 07:57:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
afarley: needinfo? (shughes)


Attachments (Terms of Use)

  None (edit)
Description Amy Farley 2017-08-02 14:00:45 EDT
We upgraded a Sat 5.6 to 5.8. After, all old kickstarts will not work, as they show a (now) incorrect url. The only way to correct is to modify each one and then republish. 

How reproducible:
Everytime

Steps to Reproduce:
1. SNAG-0007.jpg (630 KB)

kickstart with broken URL post upgrade

2. SNAG-0008.jpg (613 KB)

kickstart, post upgrade, fixed by choosing different OS, saving, then re-selecting correct OS again.

Is there a way to republish to get the correct url?
Comment 5 Tomas Lestach 2017-08-14 10:21:19 EDT
Based on Comment 4 I'm switching the BZ to MODIFIED (patch available in upstream).
Comment 9 Tomas Lestach 2017-08-25 07:52:28 EDT
*** Bug 1485010 has been marked as a duplicate of this bug. ***
Comment 12 Patrik Segedy 2017-09-12 08:54:18 EDT
On Satellite 5.8 it works asi described in Bug 1436634
spacewalk-java-2.5.14-92.el6sat.noarch
1. Change url option in advanced options to /var/satellite/rhn/kickstart/ks-rhel-x86_64-server-7-7.3
2. according to Bug 1436634 in kicstart file should be:
url --url http://<satellite_fqdn>/ks/dist/org/1/ks-rhel-x86_64-server-7-7.3
instead of:
url --url http://<satellite_fqdn>/var/satellite/rhn/kickstart/ks-rhel-x86_64-server-7-7.3

With spacewalk-java-2.5.14-96.el6sat.noarch 
1. Change url option to /var/satellite/rhn/kickstart/ks-rhel-x86_64-server-7-7.3
2. Kickstart file is correct
url --url http://<satellite_fqdn>/ks/dist/org/1/ks-rhel-x86_64-server-7-7.3

Upgrade from 5.6
1. Use older version of spacewalk-java to create valid kickstart profile through WebUI. There is same issue as described in Bug 1388073 with latest spacewalk-java
2. After upgrade to 5.8 url option changed to "--url http://<satellite_url>/rhn/kickstart/ks-rhel-x86_64-server-7-7.2". Thus kickstart is not working.
3. Install latest spacewalk-java-2.5.14-97.el6sat.noarch
4. rhn-satellite restart
5. Old kickstart remained the same. Kickstart still has wrong url path

Problem is that patch from Bug 1436634 changes url path to correct one, when provided path in advanced options is complete (--url /var/satellite/rhn/kickstart/ks-rhel-x86_64-server-7-7.2). Path like this will be changed to correct one in kickstart file (url --url <fqdn>/ks/dist/ks-rhel-x86_64-server-7-7.2). In case of this bug, the path in advanced options is just "--url /rhn/kickstart/ks-rhel-x86_64-server-7-7.2" (without /var/satellite/) and this won't result in correct kickstart file. In kickstart file remain --url <fqdn>/rhn/kickstart/... and not the correct one <fqdn>/ks/dist/...
Comment 13 Jiří Dostál 2017-10-04 15:19:23 EDT
spacewalk 7feae009d5b5e424167e5f27455f479191ed91ee
Comment 16 Patrik Segedy 2017-10-05 16:19:31 EDT
Steps to verify:
1. On Satellite 5.6 sync RHEL7 channel
2. Prepare files for custom kickstart
# mkdir -p /var/ks/images/pxeboot
# touch /var/ks/images/pxeboot/initrd.img
# touch /var/ks/images/pxeboot/vmlinuz
# chcon -R -t cobbler_var_lib_t /var/ks
and create kickstart distribution
3. Create 4 kickstart profiles with spacewalk-java-2.0.2-115
 - RHN kickstart using the API -> url in KS is OK
 - custom kickstart using the API -> url in KS is OK
 - RHN kickstart through WebUI -> broken url in KS 
 - custom kickstart through WebUI -> broken url in KS
4. Downgrade spacewalk-java* and spacewalk-taskomatic to version 2.0.2-109 and create kickstarts
 - RHN kickstart using the API -> url in KS is OK
 - custom kickstart using the API -> url in KS is OK
 - RHN kickstart through WebUI -> url in KS is OK
 - custom kickstart through WebUI -> url in KS is OK
5. Update spacewalk-java*, spacewalk-taskomatic to latest version
6. Upgrade to Satellite 5.8
7. Update to spacewalk-java-2.5.14-100.el6sat.noarch
8. Regenerate kickstarts - "rm -f /var/lib/rhn/kickstarts/wizard/*"
9. All kickstarts have correct url 

VERIFIED
Comment 20 errata-xmlrpc 2017-10-19 07:57:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2915

Note You need to log in before you can comment on or make changes to this bug.