Bug 147773 - Installed Crashed When mounting system image at end of Install
Installed Crashed When mounting system image at end of Install
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 23:20 EST by Matthew Loschiavo
Modified: 2013-08-05 21:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 16:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (339.25 KB, text/plain)
2005-02-10 23:22 EST, Matthew Loschiavo
no flags Details
syslog (41.00 KB, text/plain)
2005-02-10 23:22 EST, Matthew Loschiavo
no flags Details

  None (edit)
Description Matthew Loschiavo 2005-02-10 23:20:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
At the very end of the install, in almost the last step, after Insert Disc 1 to complete installation, /mnt/sysimage/.... fails to mount sysimage/vmlinuz.img  

The install crashes

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Reinstall OS
2.Reinstall OS
3.Reinstall OS
  

Actual Results:  Sometimes, OS crashes at end on install. 


Expected Results:  Antipicated successful install.

Additional info:
Comment 1 Matthew Loschiavo 2005-02-10 23:22:34 EST
Created attachment 110957 [details]
anacdump.txt
Comment 2 Matthew Loschiavo 2005-02-10 23:22:51 EST
Created attachment 110958 [details]
syslog
Comment 3 Matthew Loschiavo 2005-02-11 10:20:01 EST
Initially, I was experiencing this problem -- Linux Box crashed regularly with
superblock corrupted and could not rebuild.
------------------------------
The pc is a Dell Precision 360 w/ LSI Logic Scsi card connected to a Dell
Powervault 220S.  It was running RH Linux 9, kernel 2.4, with the 13 scsi drives
in the Powervault on RAID5.

On boot even prior to the any updates I have been receiving this error
Starting RAID devices: RAID5: failed to run raid set md0

checking filesystems
fsck.ext2: invalid argument /dev/md0

The superblock could not read or does not describe a correct ext2
filesystem.  If the devices is valid and it really contains an ext2
filesystem (and not swap or ufs or something else)  then the superblock 
is
corrupt  and you might try running e2fsck with an alternate superblock.

e2fsck -b 8193  device 

while trying to open /dev/md0
/boot clean 40/26104 files  17608/104391 blocks

Any ideas?  If I reformat then the error is gone and the RAID array 
works  but this only lasts a few weeks and then the power fails again; and then
I have the same problem again.  There has to be a better solution than a
monthly system restoration.  Please advise.
------------------------------

Dell recommended to update the firmware, and use a different mpt bios driver.  
I updated the firmware for the following devices.  
LSI21320-R SCSI Card MPT-IS 5.11.0x
Powervault 220 Firmware v.E.17.A06
Dell Precision v.A08

During RH installation, I am frequently encountering several problems.  The
install hangs indefinitely mid-install.  Initially, I though the cd's were bad,
but media is okay.  Keyboard goes dead, as well as mouse.  If the install
doesn't hang, upon almost completion the install, the system hangs when trying
to mount the drives /dev/md0/ (software RAID 5 array).  Consequently, the
install fails.  Yesterday, I attempted re-install the system about 6 times; 3
times it crashed in the last stage when attempting to mount drives.  2 times it
just hung indefinitely mid-install.  1 time it installed successfully, but after
applying kernel updates, the system crashed, corrupt kernel, unable to mount,
corrupt Xwindows, and couldnt reboot.  This last crash may or may not have been
my fault.



Please see error attached.  Bug is also reported to RH.
https://bugzilla.redhat.com/beta/show_bug.cgi?id=147773

13 disks Model and SN, etc.
dk32dj-72mc 24304v8117 ph09k1424818028m0254 a00 304v8117 d4d4
dk32dj-72mc 24304v7171 ph09k1424818028m0473 a00 304v7171 d4d4
dk32dj-72mc 24304v0622 ph09k1424818028m0242 a00 304v0622 d4d4
dk32dj-72mc 24304v8512 ph09k1424818028m0469 a00 304v8512 d4d4
dk32dj-72mc 24304v8350 ph09k1424818028m0472 a00 304v8350 d4d4
dk32dj-72mc 24304d5571 ph09k1424818028m0459 a00 304d5571 d4d4 
dk32dj-72mc 24304v8443 ph09k1424818028m0471 a00 304v8443 d4d4
dk32dj-72mc 24304v8559 ph09k1424818028m0465 a00 304v8559 d4d4
dk32dj-72mc 24304v8966 ph09k1424818028m0456 a00 304v8966 d4d4
dk32dj-72mc 24304v9872 ph09k1424818028m0457 a00 304v9872 d4d4
dk32dj-72mc 24304v8865 ph09k1424818028m0453 a00 304v8865 d4d4 
dk32dj-72mc 24304v5105 ph09k1424818028m0248 a00 304v5105 d4d4
dk32dj-72mc 24304v9007 ph09k1424818028m0466 a00 304v9007 d4d4



Thanks for your help.


Matthew Loschiavo
Director Of Information Technology
Marcella Fine Rugs
770.582.1800 x230



-----Original Message-----
From: Matt.Brown@hitachigst.com [mailto:Matt.Brown@hitachigst.com]On
Behalf Of HGST.NoReply@hgst.com
Sent: Friday, February 11, 2005 9:20 AM
To: mloschiavo@marcellafinerugs.com
Subject: Response (RefNum:503-567-925-4)


Matthew,
Before we can escalate a request for a firmware update, we will need the
following information:

1)  What is the exact nature of the problem? Please provide failure
details, error codes, and any messages.

2)  What troubleshooting steps have been performed to determine that a
firmware update is needed? In many cases, there are other issues that can
cause problems such as cabling or termination. Please include hardware
configuration changes, steps recommended from other Technical Support
Centers and anything else that has been tried.

3) What firmware revision is currently on the drive? If you have an Adaptec
SCSI Controller, you can find this in the SCSI BIOS. This can also by found
with the Drive Fitness Test(DFT) available on our web site.

4)  Please provide the serial number and model number of the drive. We need
this to verify warranty status. If the drive does not have a valid Hitachi
Global Storage Technologies warranty, we will not provide a firmware update
due to the possible risks involved.

NOTE:  If update is for more than one drive, all SN's and PN's from the
involved drives are required. Please keep in mind that if a firmware update
is sent, it must be performed on a NON-RAID adapter.

Thank you for contacting Hitachi Global Storage Technologies.
Matt




_______________________________
Hitachi Global Storage Technologies
US toll-free: 888.426.5214
Fax: 507.322.2419
support_usa@hitachigst.com
www.hitachigst.com
_______________________________
Comment 4 Jeremy Katz 2005-02-12 21:48:13 EST
Lots of
<4>Error -3 while decompressing!
<4>c02ed0c3(4078)->c2248000(4096)
<4>Error -3 while decompressing!
<4>c02ee0b1(4107)->c2249000(4096)

in the syslog.  This usually points to either hardware problems or the kernel.
Comment 5 Matthew Loschiavo 2005-02-14 09:30:59 EST
to resolve this problem, what should I do?
Comment 6 Jim Paradis 2005-12-08 16:38:39 EST
Are you still seeing this problem with the most recent update of RHEL2.1?
Comment 7 Jim Paradis 2006-09-14 16:41:39 EDT
Due to the age of this issue and the lack of response from the reporter, I am
closing it as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.