Bug 1477736 - rebase udisks2
rebase udisks2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: udisks2 (Show other bugs)
7.5
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Vojtech Trefny
Desktop QE
: Rebase
Depends On: 1480294 1510667 1525418
Blocks: 1469559
  Show dependency treegraph
 
Reported: 2017-08-02 14:48 EDT by David Lehman
Modified: 2018-04-24 03:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: udisks2-2.7.3-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 11:43:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0868 None None None 2018-04-10 11:44 EDT

  None (edit)
Description David Lehman 2017-08-02 14:48:51 EDT
A rebase of udisks2 will pick up a great deal of work on modularity and stability,  including the work done under the storaged fork.

AFAIK this rebase would enable the cockpit team to drop the cockpit-storaged package.

New dependencies: libblockdev (in fedora since F18 or so, used by blivet/anaconda since then)


(new) udisks2 upstream: https://github.com/storaged-project/udisks/
libblockdev upstream: https://github.com/storaged-project/libblockdev/
Comment 8 Sandro Bonazzola 2017-12-14 06:24:35 EST
Failing QA due to bug #1525418
Comment 9 Yaakov Selkowitz 2017-12-14 16:53:18 EST
(In reply to Sandro Bonazzola from comment #8)
> Failing QA due to bug #1525418

Should be fixed in bug 1510667.
Comment 10 Sandro Bonazzola 2017-12-19 07:47:14 EST
Moving back to assigned and failing QE again.
changing the package which was requiring storaged doesn't fix a wrong spec file in udisks2.
Please see https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages
Comment 11 Yaakov Selkowitz 2017-12-19 10:26:36 EST
(In reply to Sandro Bonazzola from comment #10)
> Moving back to assigned and failing QE again.

How so exactly?

> changing the package which was requiring storaged doesn't fix a wrong spec
> file in udisks2.

It does, because...

> Please see
> https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.
> 2FReplacing_Existing_Packages

Which explicitly says:

"If a package supersedes/replaces an existing package without being a sufficiently compatible replacement as defined above, use only the Obsoletes: line from the above example."

I believe this is such a case.
Comment 12 Sandro Bonazzola 2017-12-21 03:45:50 EST
(In reply to Yaakov Selkowitz from comment #11)

> "If a package supersedes/replaces an existing package without being a
> sufficiently compatible replacement as defined above, use only the
> Obsoletes: line from the above example."
> 
> I believe this is such a case.

Ok, fir enough, moving back to QE
Comment 13 Bohdan Milar 2018-01-16 07:21:40 EST
New version available on all archs. TPS OK.
Comment 16 errata-xmlrpc 2018-04-10 11:43:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0868

Note You need to log in before you can comment on or make changes to this bug.