Bug 147774 - failed install over existing boot partition results in unbootable system
failed install over existing boot partition results in unbootable system
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 00:27 EST by Travis Fisher
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-12 21:41:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Fisher 2005-02-11 00:27:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.8.2 (KHTML, like Gecko) Safari/85.8.1

Description of problem:
I was attempting to install Fedora Core 3 on a dual boot system.  The previous setup used grub installed on the MBR with its image2 and other configuration files on the old linux partition.  I instructed anaconda to reformat that partition and use it as the root for the fedora install.  Partway through the installation some error occurred, which I don't have enough understanding of to file a meaningful bug report.  The result of this was a half-way installed system.  Okay, stuff happens.  But since anaconda leaves the grub setup until last, I was left with an unbootable system.  (Grub would just report "error 15" and halt, presumably because it couldn't find the now-blown-away image2...)  

As it happens, I was attempting to save myself the trouble of burning any cd images -- I had loaded the isolinux image with grub and was attempting an ftp install.  So I was just dead until I could get a rescue disk.    

The  upshot is, at least from my perspective it looks like it would be a robustness
enhancement to have anaconda do bootloader installation as the first thing after partitioning, as opposed to the last thing.  Or, if you can think of other situations where the opposite order is better, to have anaconda intelligently decide which order is safer.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:

    

Additional info:
Comment 1 Jeremy Katz 2005-02-12 21:41:46 EST
Unfortunately, this ends up being difficult to impossible to do based
on dependencies needed for grub installation, etc.

Note You need to log in before you can comment on or make changes to this bug.