This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1477749 - legion won't build on s390x
legion won't build on s390x
Status: CLOSED RAWHIDE
Product: Fedora EPEL
Classification: Fedora
Component: legion (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Junghans
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 15:45 EDT by Neale Ferguson
Modified: 2017-08-04 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 15:56:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested patch for s390x build (392 bytes, patch)
2017-08-02 15:45 EDT, Neale Ferguson
no flags Details | Diff

  None (edit)
Description Neale Ferguson 2017-08-02 15:45:52 EDT
Created attachment 1308447 [details]
Suggested patch for s390x build

Description of problem:
Build fails due to missing include file

Version-Release number of selected component (if applicable):
17.05.0

How reproducible:
Always fails

Steps to Reproduce:
1. Run rpmbuild

Actual results:
Failed build


Expected results:
Successful build


Additional info:
Suggested patch attach
Comment 1 Christoph Junghans 2017-08-02 15:57:45 EDT
Submitted upstream.
Comment 2 Christoph Junghans 2017-08-03 11:47:40 EDT
Hmm, using this patch, https://koji.fedoraproject.org/koji/taskinfo?taskID=21017045, shows some unrelated issue on aarch64:
*** FATAL ERROR: mmap result 0x0000ffff a6e4d000 is not aligned to GASNET_PAGESIZE 65536 (0x10000)
NOTICE: Before reporting bugs, run with GASNET_BACKTRACE=1 in the environment to generate a backtrace

I will have to have a look at that, too.
Comment 3 Christoph Junghans 2017-08-03 12:57:07 EDT
@neale, please let me know when the updated  kernel-headers is available, we will need that for #1453092 as well, which then would allow us to get a fully parallel version of legion on s390x.
Comment 4 Christoph Junghans 2017-08-04 15:56:38 EDT
https://koji.fedoraproject.org/koji/taskinfo?taskID=21051665

Note You need to log in before you can comment on or make changes to this bug.