Bug 1477754 - RGW: close complete-multipart-upload race
RGW: close complete-multipart-upload race
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
2.3
All All
unspecified Severity high
: rc
: 2.4
Assigned To: Matt Benjamin (redhat)
Tamil
Bara Ancincova
:
Depends On:
Blocks: 1473436 1479701
  Show dependency treegraph
 
Reported: 2017-08-02 16:10 EDT by Matt Benjamin (redhat)
Modified: 2017-10-18 14:14 EDT (History)
11 users (show)

See Also:
Fixed In Version: RHEL: ceph-10.2.7-33.el7cp Ubuntu: ceph_10.2.7-34redhat1
Doc Type: Bug Fix
Doc Text:
.A new serialization mechanism for upload completions is supported A race condition in completion of multipart upload operations could fail if a client retried its complete operation while the original completion was still in progress. As a consequence, a multipart upload failed, especially, when it was slow to complete. This update introduces a new serialization mechanism for upload completions, and the multipart upload failures no longer occur.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-17 14:12:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 20861 None None None 2017-08-02 16:10 EDT

  None (edit)
Description Matt Benjamin (redhat) 2017-08-02 16:10:30 EDT
Description of problem:
If a client retries a complete-multipart-upload operation that is still in progress, the gc process incorrectly deletes part objects.
Comment 7 Tamil 2017-09-22 20:33:57 EDT
steps used to verify the bug:

ceph version 10.2.7-38.el7cp (e62d5f5565301d83f42d01940f7ca21ad23414da)

1. sudo s3cmd mb s3://BUCKET1
2. sudo s3cmd put /home/ubuntu/rhceph-2.0-rhel-7-x86_64.iso s3://BUCKET1 - 2 instances running in parallel
3. sudo s3cmd get s3://BUCKET/rhceph-2.0-rhel-7-x86_64.iso 1g.iso - verify the size of the file.
no error or deletes seen in rgw log.
Comment 13 errata-xmlrpc 2017-10-17 14:12:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2903

Note You need to log in before you can comment on or make changes to this bug.