Bug 1477785 - Openvswitch crashed when trying to spawn instances
Openvswitch crashed when trying to spawn instances
Status: CLOSED DUPLICATE of bug 1468631
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch-dpdk (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Open vSwitch development team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 20:31 EDT by PURANDHAR SAIRAM MANNIDI
Modified: 2017-08-02 21:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 21:08:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description PURANDHAR SAIRAM MANNIDI 2017-08-02 20:31:11 EDT
Description of problem:
Openvswitch crashed when trying to spawn VNF instances and add allowed address pairs

Version-Release number of selected component (if applicable):
openvswitch-2.6.1-3.git20161206.el7fdb.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Spawn a VNF Instance
2. Add 10 allowed address pairs
3.

Actual results:
OVS-vswitchd is crashed

Expected results:
VNF running and traffic flowing
Comment 1 Aaron Conole 2017-08-02 21:08:29 EDT
Core dump (from the case):

[root@wsfd-netdev60 ~]# gdb /usr/sbin/ovs-vswitchd core.1627
(gdb) bt
#0  rte_mempool_default_cache (mp=<optimized out>, mp=<optimized out>, 
    lcore_id=<optimized out>)
    at /usr/src/debug/openvswitch-2.6.1/dpdk-16.11/x86_64-native-linuxapp-gcc/include/rte_mempool.h:1017
#1  rte_mempool_put_bulk (n=0, obj_table=0x7effedff0480, mp=0x0)
    at /usr/src/debug/openvswitch-2.6.1/dpdk-16.11/x86_64-native-linuxapp-gcc/include/rte_mempool.h:1174
#2  enic_free_wq_bufs (wq=wq@entry=0x7ee4bffcd5b0, 
    completed_index=completed_index@entry=967)
    at /usr/src/debug/openvswitch-2.6.1/dpdk-16.11/drivers/net/enic/enic_rxtx.c:429
#3  0x00007f01954cb737 in enic_cleanup_wq (enic=<optimized out>, 
    wq=wq@entry=0x7ee4bffcd5b0)
    at /usr/src/debug/openvswitch-2.6.1/dpdk-16.11/drivers/net/enic/enic_rxtx.c:442
#4  0x00007f01954cb77f in enic_xmit_pkts (tx_queue=0x7ee4bffcd5b0, 
    tx_pkts=0x7effedff8550, nb_pkts=<optimized out>)
    at /usr/src/debug/openvswitch-2.6.1/dpdk-16.11/drivers/net/enic/enic_rxtx.c:470
#5  0x00007f01953d4566 in rte_eth_tx_burst (nb_pkts=<optimized out>, 
    tx_pkts=<optimized out>, queue_id=0, port_id=<optimized out>)
    at /usr/src/debug/openvswitch-2.6.1/dpdk-16.11/x86_64-native-linuxapp-gcc/include/rte_ethdev.h:2819


This is the same as #1468631

*** This bug has been marked as a duplicate of bug 1468631 ***

Note You need to log in before you can comment on or make changes to this bug.