Bug 147782 - logrotate script errors
Summary: logrotate script errors
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: psacct (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-02-11 08:55 UTC by Joe Orton
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 11:24:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2005-02-11 08:55:20 UTC
[root@trash logrotate.d]# pwd
/etc/logrotate.d
[root@trash logrotate.d]# rpm -qf psacct
psacct-6.3.2-34.fc4

logrotate cron job produces errors:

/etc/cron.daily/logrotate:

error: psacct:7 unknown option 'endscript' -- ignoring line
error: psacct:9 unknown option 'delatcompress' -- ignoring line

Comment 1 Michal Jaegermann 2005-02-14 01:29:04 UTC
There are typos in /etc/logrotate.d/psacct.
'prerotate' on line 5 is commented out causing complaints on line 7
and 'delatcompress' should read 'delaycompress'.

Also in other scripts lines like 'prerotate' and 'endscript' do
NOT start on the left margin.

Comment 2 Ivana Varekova 2005-02-16 11:24:44 UTC
Thank you for your notice
The problem was fixed (fixed version is 6.3.2-35)
Ivana Varekova


Note You need to log in before you can comment on or make changes to this bug.