Bug 1477835 - [RFE] To have the ability to use Roles within Roles to manage filters
[RFE] To have the ability to use Roles within Roles to manage filters
Status: CLOSED DUPLICATE of bug 1480424
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.2.10
All All
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 01:05 EDT by Anand Agrawal
Modified: 2017-08-14 10:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 01:07:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Marek Hulan 2017-08-04 08:02:34 EDT
I'd suggest using usergroups for composing roles. We'd like to avoid extra complexity by adding roles nesting. User groups already support nesting and can be assigned multiple roles so I think it should cover the use case. Please let us know whether this works for customer.

We'd also like to implement some wizards for creation and managing roles, e.g. create a role "to manage all hosts in this host collection". This is already tracked in separate BZ.
Comment 2 Anand Agrawal 2017-08-08 01:39:52 EDT
Hello Marek,

Customer has confirmed they can make that work, but it uncovers a related issue.

It's difficult to see what permissions a specific user actually has from the WebUI (and from the CLI, too).  

Is there a simple way to see what access a particular user has (a consolidated rollup of filters that apply to a given user)?

we'd really like to not only see what filters a user has, but what Role provides it.  Also, if the same filter is provided by multiple Roles/Groups, we'd like to know ALL sources.
Comment 3 Marek Hulan 2017-08-08 02:48:23 EDT
In next Satellite version, there will be more information displayed in User edit form under Roles tab. The customer could see all user groups that user has been assigned and roles that they grant - tracked under BZ 1426957. There's no page listing filters/permissions though. So this might be an RFE. It would probably be best to create a new BZ for that and close this one.
Comment 4 Anand Agrawal 2017-08-11 01:07:53 EDT
As per the discussion in C#3, I am closing this RFE and have opened another RFE for the same.

https://bugzilla.redhat.com/show_bug.cgi?id=1480424

Regards,
Anand

*** This bug has been marked as a duplicate of bug 1480424 ***

Note You need to log in before you can comment on or make changes to this bug.