This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1477891 - heat api fails to list resources due to wrong value of needed_by in undercloud
heat api fails to list resources due to wrong value of needed_by in undercloud
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
10.0 (Newton)
All Linux
medium Severity medium
: z5
: 10.0 (Newton)
Assigned To: Zane Bitter
Ronnie Rasouli
: Triaged, ZStream
Depends On: 1469542
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 03:14 EDT by Rabi Mishra
Modified: 2017-09-28 12:39 EDT (History)
12 users (show)

See Also:
Fixed In Version: openstack-heat-7.0.5-2.el7ost
Doc Type: Bug Fix
Doc Text:
If a stack was created using a version of Heat from RHEL-OSP 7 or earlier, listing resources for the stack would fail beginning with the Heat version from OSP 10, with an error calculating the 'required_by' data. In addition, even for stacks created with later versions of Heat, the 'required_by' field was not populated, unless the convergence_engine option was enabled (which is the default starting with OSP 10) at the time the stack was created. Heat now correctly populates the 'required_by' field without error.
Story Points: ---
Clone Of: 1469542
Environment:
Last Closed: 2017-09-28 12:39:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1703703 None None None 2017-08-03 03:14 EDT
OpenStack gerrit 483574 None None None 2017-08-03 03:14 EDT

  None (edit)
Comment 5 errata-xmlrpc 2017-09-28 12:39:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2826

Note You need to log in before you can comment on or make changes to this bug.