Bug 147790 - "xwdtopnm: object too large"
"xwdtopnm: object too large"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 06:01 EST by Jonathan Kamens
Modified: 2013-07-02 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: 10.26.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 04:21:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bzipped xwd that exhibits this problem (47.35 KB, application/octet-stream)
2005-02-15 22:30 EST, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2005-02-11 06:01:13 EST
I dump a window with xwd and then try to convert it with xwdtopnm from
netpbm-10.26-1.  I get: "xwdtopnm: object too large".  ImageMagick
says it's a 937x918 window dump.
Comment 1 Jindrich Novy 2005-02-15 09:10:28 EST
Hello Jonathan,

I was unable to reproduce it with netpbm-10.26-1 and
ImageMagick-6.0.7.1-4. Could you attach here the xwd image that needs
to be converted with xwdtopnm?

Jindrich
Comment 2 Jonathan Kamens 2005-02-15 22:30:08 EST
Created attachment 111122 [details]
bzipped xwd that exhibits this problem

Unbzip this and run "xwdtopnm < mozilla.xwd" and it produces the "object too
large" error I reported.  Interestingly, when I run "xwdtopnm -verbose <
mozilla.xwd" I get "Input is different endianness from this machine" before I
get "object too large".
Comment 3 Jindrich Novy 2005-03-14 04:02:39 EST
You're right. The problem is with multiplication overflow checking, where
bytes_per_line is got from a wrong structure (h11P), but the values with which
are lately operated are in h11FixedP, so the overflow check generates bogus
warnings as the h11P structure contains integers with incompatible endianess.

I fixed the overflow check and will close this bug after new netpbm is built.

Thanks,
Jindrich
Comment 4 Jindrich Novy 2005-03-14 04:21:32 EST
New netpbm is just built.

Note You need to log in before you can comment on or make changes to this bug.