Bug 1477909 - Prevent /tmp from filling with openshift-sdn-debug logs. Is there a way to change the openshift-sdn-debug log path to /var/log and not /tmp?
Prevent /tmp from filling with openshift-sdn-debug logs. Is there a way to c...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.4.1
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Ravi Sankar
Meng Bo
:
Depends On:
Blocks: 1485742
  Show dependency treegraph
 
Reported: 2017-08-03 03:54 EDT by Miheer Salunke
Modified: 2017-08-31 13:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1485742 (view as bug list)
Environment:
Last Closed: 2017-08-31 13:16:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ravi Sankar 2017-08-07 15:49:59 EDT
By default 'oc adm diagnostics NetworkCheck' logs errors under '/tmp/openshift' and this can be configured with '--network-logdir' flag.

Looking at the filename format under /tmp (openshift-sdn-debug-<XXXXXXXXX>), this seems to be generated by unsupported sdn script 'https://github.com/openshift/openshift-sdn/blob/master/hack/debug.sh' and not 'oc adm diagnostics'. If the user still want to use this script, they can change the logdir to desired path in debug.sh (logdir is initialized to /tmp/openshift-sdn-debug-xxx on line 569).
Comment 2 Phil Cameron 2017-08-07 16:31:47 EDT
"oc adm diagnostics NetworkCheck" does not seem to be documented. Maybe it could be added to admin_guide/diagnostics_tool.adoc?
Comment 3 Ben Bennett 2017-08-31 13:16:03 EDT
As Ravi said, it looks like the large directories are from https://github.com/openshift/openshift-sdn/blob/master/hack/debug.sh

You can change the directory the temp files are written to by setting TMPDIR in the environment.

Note You need to log in before you can comment on or make changes to this bug.