Bug 1477928 - thermostat local does not start because of unsatisfied OSGi bundle dependencies
thermostat local does not start because of unsatisfied OSGi bundle dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thermostat (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 05:15 EDT by René Kraneis
Modified: 2017-08-15 13:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: thermostat-1.6.6-3.1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 13:20:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of `thermostat local` (3.51 KB, text/plain)
2017-08-03 05:15 EDT, René Kraneis
no flags Details
Output of `dnf install thermostat` (39.96 KB, text/plain)
2017-08-03 05:16 EDT, René Kraneis
no flags Details

  None (edit)
Description René Kraneis 2017-08-03 05:15:55 EDT
Created attachment 1308662 [details]
Output of `thermostat local`

Description of problem:

Thermostat does not start locally (thermostat local) because of unsatisfied OSGi bundle dependencies: Unresolved requirements: [[com.redhat.thermostat.vm.heap.analysis.common [56](R 56.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.lucene.analysis)(version>=5.5.0)(!(version>=6.0.0)))]

Version-Release number of selected component (if applicable):
1.6.6-3


How reproducible:
aways

Steps to Reproduce:
1. install thermostat
2. run `thermostat local`

Actual results:
Thermostat exits with an error message.

Expected results:
Thermostat should start without an error message.


Additional info:
Dnf installs lucene 6.1.0-3 which is higher than the OSGi requirement of < 6.0.0 which might be the problem.
Comment 1 René Kraneis 2017-08-03 05:16 EDT
Created attachment 1308663 [details]
Output of `dnf install thermostat`
Comment 2 Severin Gehwolf 2017-08-03 06:05:50 EDT
Thanks for the bug report. I'll take a look.
Comment 4 René Kraneis 2017-08-03 09:37:20 EDT
Hi Severin,

thanks for the quick response. The first build works. How can I test the second after installation?

Kind regards,
René
Comment 5 Severin Gehwolf 2017-08-03 10:19:13 EDT
Thanks for testing it. I'll push and update soon.

(In reply to René Kraneis from comment #4)
> How can I test the
> second after installation?

$ rm -rf ~/.thermostat-1.6
$ thermostat local

would use it if you have -webapp installed. Depending whether or not the -webapp package is installed it'll use HTTP based storage or mongodb storage directly. The difference is that the former adds a security layer on top. For most cases you don't need to use -webapp for local mode.
Comment 6 Fedora Update System 2017-08-03 12:49:00 EDT
thermostat-1.6.6-3.1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6edef53aa3
Comment 7 Fedora Update System 2017-08-04 22:21:08 EDT
thermostat-1.6.6-3.1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6edef53aa3
Comment 8 Fedora Update System 2017-08-15 13:20:47 EDT
thermostat-1.6.6-3.1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.