Bug 1477933 - Copy Service Labels on route creating page does not work
Copy Service Labels on route creating page does not work
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ---
: 3.6.z
Assigned To: Samuel Padgett
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 05:24 EDT by XiaochuanWang
Modified: 2017-09-07 23:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the "Copy Service Labels" link in the "Create Route" form did not correctly copy the labels from the service to the new route. It has been fixed to copy the selected service's labels.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-07 23:15:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description XiaochuanWang 2017-08-03 05:24:32 EDT
Description of problem:
Create service with labels, go to route create page as below:
https://...project/xiaowan-st/create-route?service=database
or https://...project/xiaowan-st/create-route
Select a service and click "Copy Service Labels", the link does not work, nothing happened.


Version-Release number of selected component (if applicable):
OpenShift Master:      v3.6.173.0.2
Kubernetes Master:     v1.6.1+5115d708d7 

How reproducible:
Always

Steps to Reproduce:
1. oc new-app https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json
2. Go to Service -> database -> click "Create route", then scroll down to the "Copy Service Labels" and click it
3. Go to Routes page, click "Create Route", then scroll down to the "Copy Service Labels" and click it

Actual results:
2&3 Nothing happened.

Expected results:
2&3 Since the service is chosen, the labels for database should be filled automatically to route when user click "Copy Service Labels"

Additional info:
Comment 3 Samuel Padgett 2017-08-22 09:16:51 EDT
Note that the copy service labels link was recently removed (in 3.7). The labels are just prefilled now.

https://github.com/openshift/origin-web-console/pull/1940
Comment 4 Samuel Padgett 2017-08-24 14:54:34 EDT
3.6 backport: https://github.com/openshift/origin-web-console/pull/1964
Comment 6 XiaochuanWang 2017-08-29 01:32:41 EDT
Verified on OCP
OpenShift Master:     v3.6.173.0.21
Kubernetes Master:    v1.6.1+5115d708d7 

Labels could be filled in by "Copy Service Labels":
app: ruby-helloworld-sample
template: application-template-stibuild

The labels from service:
  labels:
    app: ruby-helloworld-sample
    template: application-template-stibuild
Comment 8 errata-xmlrpc 2017-09-07 23:15:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2642

Note You need to log in before you can comment on or make changes to this bug.