Bug 147795 - find-debuginfo.sh doesn't recognize setuid binaries as binaries
find-debuginfo.sh doesn't recognize setuid binaries as binaries
Status: CLOSED DUPLICATE of bug 100963
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 08:06 EST by Tomas Mraz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-13 06:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Mraz 2005-02-11 08:06:41 EST
Description of problem:
find-debuginfo.sh has: sed -n -e 's/^\(.*\):[  ]*ELF.*, not stripped/\1/p'
but current version of file reports for example:
/usr/libexec/openssh/ssh-keysign: setuid ELF 64-bit LSB executable, ....

Version-Release number of selected component (if applicable):
file-4.12-3
rpm-4.4.1-0.20

How reproducible:
100%

Steps to Reproduce:
1. Build a rpm with setuid executable
2. See that the executable isn't stripped.
Comment 1 Robin Green 2005-06-26 11:50:57 EDT
This is a duplicate of bug 100963
Comment 2 Jeff Johnson 2005-07-13 06:57:50 EDT

*** This bug has been marked as a duplicate of 100963 ***

Note You need to log in before you can comment on or make changes to this bug.