Bug 1477961 - [UI] - Failed to create bond from interfaces that has labeled networks attached
[UI] - Failed to create bond from interfaces that has labeled networks attached
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
4.2.0
x86_64 Linux
low Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Ales Musil
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 06:29 EDT by Michael Burman
Modified: 2017-12-20 05:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:49:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
engine logs (56.85 KB, application/x-gzip)
2017-08-03 06:29 EDT, Michael Burman
no flags Details
record flow (1.26 MB, application/x-gzip)
2017-08-03 06:30 EDT, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80587 master MERGED webadmin: Fix Failed to create bond from interfaces that has labeled networks attached 2017-08-15 07:42 EDT

  None (edit)
Description Michael Burman 2017-08-03 06:29:41 EDT
Created attachment 1308679 [details]
engine logs

Description of problem:
[UI] - Failed to created bond from interfaces that has labeled networks attached.

If trying to create a bond from interfaces that has labeled networks attached, we failing with UI exception on the creation of the bond:
2017-08-03 13:06:56,876+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-15) [] Permutation name: 301C94023E9B382D73E34D90D2C1CBCA
2017-08-03 13:06:56,907+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-15) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'Tl' of undefined
        at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_131]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_131]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:70) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:]

And with engine error when trying to approve the operation:
"Cannot setup Networks. Network interface 'ens1f0' cannot be labeled. Label can be provided only to interfaces or to bonds (not to slaves nor vlans)."

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170802131956.git268ecf3.el7.centos
Relevant for 4.1.5-0.1.el7 as well.

How reproducible:
100%

Steps to Reproduce:
1. Create vlan network net1 with label label1
2. Create vlan network net2 with label label2
3. Attach labeled net1 to eth2 and labeled net2 to eth3
4. Try to create bond from eth2 and eth3 via the setup networks dialog 

Actual results:
Failed with UI exception and engine error.

Expected results:
Should work as expected. There should be no problem to create bond from 2 interfaces that has labeled networks attached, as long both networks can live together(for example 2 vlan networks).
Comment 1 Michael Burman 2017-08-03 06:30 EDT
Created attachment 1308680 [details]
record flow
Comment 2 Michael Burman 2017-08-03 06:31:21 EDT
2017-08-03 13:22:34,152+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-5) [] Permutation name: FEF8147E6E08A91BD61EF99653855432
2017-08-03 13:22:34,153+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-5) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 'Il' of undefined
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_131]
Comment 3 Michael Burman 2017-08-03 06:44:20 EDT
This happens as well when only one of the slaves has a labeled network attached and the second slave only network attached without label.
Comment 4 Michael Burman 2017-08-28 10:06:58 EDT
Verified on - 4.2.0-0.0.master.20170827084901.git3fdb878.el7.centos
Comment 5 Sandro Bonazzola 2017-12-20 05:49:43 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.