Bug 1477963 - Export of VM without disks does not log the export success
Export of VM without disks does not log the export success
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Eyal Shenitzky
Natalie Gavrielov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 06:40 EDT by Natalie Gavrielov
Modified: 2017-12-20 06:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:44:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
engine.log (135.52 KB, application/zip)
2017-08-03 06:40 EDT, Natalie Gavrielov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80685 master MERGED core: Add callback mechanism to ExportVmCommand 2017-09-24 14:32 EDT

  None (edit)
Description Natalie Gavrielov 2017-08-03 06:40:30 EDT
Created attachment 1308681 [details]
engine.log

Description of problem:
Following issue 1429499, I noticed that the same goes for exporting a "diskless" VM:
When exporting a VM without any disks attached, the "Vm vm_name was exported successfully to export_domain" audit log is not logged like when exporting a VM that has disks.

Version-Release number of selected component:
ovirt-engine-4.2.0-0.0.master.20170725202023.git561151b.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
Export a VM without disks to an export domain.

Actual results:
No "exported successfully" audit log message.

Expected results:
"Vm vm_name was exported successfully to export_domain" audit log message should be logged.
Comment 1 Yaniv Kaul 2017-10-29 07:25:44 EDT
Is this correctly targeted for 4.3?
Comment 2 Allon Mureinik 2017-10-29 07:27:13 EDT
(In reply to Yaniv Kaul from comment #1)
> Is this correctly targeted for 4.3?
No, this is a mistake. It's merged to 4.2.
Comment 3 Natalie Gavrielov 2017-10-31 08:18:18 EDT
Verified, ovirt-engine-4.2.0-0.0.master.20171030210714.gitef6bb9c.el7.centos.noarch.
Comment 4 Sandro Bonazzola 2017-12-20 06:44:59 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.