Bug 1478001 - Cannot edit new cluster memory optimization in Guide Me dialog
Cannot edit new cluster memory optimization in Guide Me dialog
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.1.4.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.1
: ---
Assigned To: bugs@ovirt.org
Liran Rotenberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 08:36 EDT by Jiri Belka
Modified: 2018-02-12 06:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-12 06:47:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
screenshot (73.52 KB, image/png)
2017-08-03 08:36 EDT, Jiri Belka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 86204 master MERGED webadmin: Guide me cluster optmization 2018-01-11 08:54 EST

  None (edit)
Description Jiri Belka 2017-08-03 08:36:25 EDT
Created attachment 1308716 [details]
screenshot

Description of problem:

I enabled Memory Optimization for Desktop Load and enabled KSM but there's still popup which informs one should enable KSM _or_ balooning. There's also *typo* in the message, it is not 'balooning' but 'ballooning'.

~~~
Operation Canceled

Error while executing action: KSM or balooning must be enabled to allow memory optimization
~~~

See screenshot.

Version-Release number of selected component (if applicable):
rhevm-4.1.4.2-0.1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. create new dc/cl
2. enable mem optimization for desktop load
3. enable ksm
4. click ok

Actual results:
popup which informs to either enable ksm or ballooning + typo in message

Expected results:
either it should work or message should replace 'or' to 'and', also no typo there.

Additional info:
Comment 2 Jiri Belka 2017-08-03 08:41:20 EDT
Well, I can't "submit" the dialog even both KSM and ballooning is enabled.
Comment 3 Jiri Belka 2017-08-03 08:47:37 EDT
It does not work from Guide Me dialog in this steps:
- create dc
- guide me (configure cluster)
- edit cluster settings with mem optimization

this fails but if you just save cluster without mem optimization and edit it to have mem optimization it does work.
Comment 4 Martin Sivák 2017-08-16 06:06:19 EDT
Hi Greg, can the UX team help us with this? We have probably never touched the Guide me dialogs before.
Comment 5 Greg Sheremeta 2017-08-16 07:51:59 EDT
"Guide Me" is just a dialog that links to other dialogs -- a "wizard". From what Jiri says, I'd guess the problem is still in the cluster dialog. But I can take a quick look.
Comment 6 Martin Sivák 2017-10-12 07:40:07 EDT
Please do, it would help us tremendously.
Comment 7 Martin Sivák 2017-11-01 07:14:42 EDT
Just for the record - optimization requires either ksm or ballooning to be enabled. So we either add that to the wizard as well or remove optimization from it.
Comment 8 Greg Sheremeta 2018-01-10 11:57:07 EST
Actually, Alexander, would you mind taking a look or offering your opinion? I don't know nearly as much about the model stuff as you do. Thanks!
Comment 9 Alexander Wels 2018-01-10 15:24:08 EST
This is a prime example of why copy and paste is bad. The problem is basically in DataCenterGuideModel we are passing the ClusterModel to the popup dialog and then once it returns we populate the object from that to pass to the back to create the new cluster. We do the same thing in the ClusterListModel. At some point in time those were the same, while changes happened to the dialog the cluster list model method was updated but since hardly anyone uses the DataCenterGuideModel it wasn't.

I will post a patch soon that will make the ClusterListModel method that populates the object for the backend public static and that will also call it from the DataCenterGuideModel.
Comment 11 Greg Sheremeta 2018-01-11 08:58:25 EST
@Martin this is all fixed now (thanks Alex!) so can target to 4.2.2
Comment 12 Liran Rotenberg 2018-02-04 06:18:46 EST
Verified on:
ovirt-engine-4.2.1.5-0.1.el7.noarch

Steps of verification:
1. Create new DC
2. Guide me (configure cluster)
3. Edit cluster settings with memory optimization
4. Click OK

Results:
Enabling memory optimization without anything else results in:
"Error while executing action: KSM or ballooning must be enabled to allow memory optimization."

Enabling to the above memory balloon/KSM or both and clicking OK is working and creating a cluster.
Comment 13 Sandro Bonazzola 2018-02-12 06:47:37 EST
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.