Bug 1478014 - Swift containers are stuck restarting
Swift containers are stuck restarting
Status: CLOSED DUPLICATE of bug 1474866
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Angus Thomas
Amit Ugol
scale_lab
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 09:04 EDT by Sai Sindhur Malleni
Modified: 2017-12-14 09:49 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 21:39:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sai Sindhur Malleni 2017-08-03 09:04:18 EDT
Description of problem: Some swift containers on controller-0 are stuck restarting as follows 
https://gist.github.com/smalleni/47bea700ad4b6fe5c1d438e93926a9a5

Using docker log to probe  the logs I see messages such as 
https://gist.github.com/smalleni/87291895763f8033cfb7ee811e860d60
https://gist.github.com/smalleni/a1bb00762c29e1125378ce183464d405
on the containers stuck restarting

Version-Release number of selected component (if applicable):
OSP 12 Build 2017-07-27.1

How reproducible:


Steps to Reproduce:
1. Deploy OSP 12 with containers
2.
3.

Actual results:
Some swift containers are stuck restarting

Expected results:
Containers should run normally

Additional info:
Comment 1 Pete Zaitcev 2017-08-03 14:45:58 EDT
Logs captured by the reporter point at rings absent. It's hardly anything
Swift can do anything about. I'm switching the component to Director, so
relevant developers are aware of the problem.
Comment 4 Thiago da Silva 2017-08-09 21:39:49 EDT

*** This bug has been marked as a duplicate of bug 1474866 ***

Note You need to log in before you can comment on or make changes to this bug.