Bug 1478020 - UI error on login the first time after engine is restarted
UI error on login the first time after engine is restarted
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Alexander Wels
Lucie Leistnerova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 09:10 EDT by Lucie Leistnerova
Modified: 2017-12-20 05:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:43:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
ui_error (40.94 KB, image/png)
2017-08-03 09:10 EDT, Lucie Leistnerova
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80343 master MERGED webadmin: fix ui exception 2017-08-09 14:33 EDT

  None (edit)
Description Lucie Leistnerova 2017-08-03 09:10:44 EDT
Created attachment 1308727 [details]
ui_error

Description of problem:
After login into admin portal UI error appears 
Exception caught: (TypeError) : plu(...).contentWindow.document.body is null 
It's only the first time after engine is restarted.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170802210223.git338a2bc.el7.centos.noarch

How reproducible: 3/5, it should be exactly after restart


Steps to Reproduce:
1. restart service ovirt-engine
2. go fast to www, reload until welcome page is shown and log into admin portal

Actual results: ui error appears, see attachment


Expected results: no ui error


Additional info:
ui.log

2017-08-03 14:08:52,188+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-4) [] Permutation name: 10CB56F98F589168F3AA29C23C6C897D
2017-08-03 14:08:52,189+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-4) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : plu(...).contentWindow.document.body is null
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_141]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_141]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.event.logical.shared.ResizeEvent.fire(ResizeEvent.java:40) [gwt-servlet.jar:]
        at com.google.gwt.user.client.Window.onResize(Window.java:862) [gwt-servlet.jar:]
        at Unknown.onresize<(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/?locale=en_US)
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:236) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:275) [gwt-servlet.jar:]
        at Unknown.Ku/<(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/?locale=en_US)
        at Unknown.trigger(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/theme/00-ovirt.brand/ovirt-js-dependencies/jquery/dist/jquery.min.js)
        at Unknown.trigger/<(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/theme/00-ovirt.brand/ovirt-js-dependencies/jquery/dist/jquery.min.js)
        at Unknown.each(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/theme/00-ovirt.brand/ovirt-js-dependencies/jquery/dist/jquery.min.js)
        at Unknown.each(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/theme/00-ovirt.brand/ovirt-js-dependencies/jquery/dist/jquery.min.js)
        at Unknown.trigger(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/theme/00-ovirt.brand/ovirt-js-dependencies/jquery/dist/jquery.min.js)
        at Unknown.forceResize/<(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/theme/00-ovirt.brand/patternfly-3.25.1-custom.min.js)
        at Unknown.anonymous(Unknown)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) : plu(...).contentWindow.document.body is null
        at org.ovirt.engine.ui.webadmin.section.main.view.DynamicUrlContentTabView.$lambda$1(DynamicUrlContentTabView.java:29)
        at org.ovirt.engine.ui.webadmin.section.main.view.DynamicUrlContentTabView$lambda$1$Type.onResize(DynamicUrlContentTabView.java:29)
        at com.google.gwt.event.logical.shared.ResizeEvent.dispatch(ResizeEvent.java:104) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
        ... 14 more
Comment 1 Lucie Leistnerova 2017-09-01 06:31:34 EDT
no UI error

verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170831223128.git34f4d69.el7.centos.noarch
Comment 2 Sandro Bonazzola 2017-12-20 05:43:15 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.