Bug 1478046 - /etc/sysconfig/gluster-block file, which defines 'GB_GLFS_LRU_COUNT' value, should be persistent in RHGS image
/etc/sysconfig/gluster-block file, which defines 'GB_GLFS_LRU_COUNT' value, s...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: CNS-deployment (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity high
: ---
: CNS 3.6
Assigned To: Saravanakumar
krishnaram Karthick
:
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-08-03 09:29 EDT by krishnaram Karthick
Modified: 2017-10-11 03:12 EDT (History)
13 users (show)

See Also:
Fixed In Version: cns-deploy-5.0.0-29.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:12:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnaram Karthick 2017-08-03 09:29:12 EDT
Description of problem:
As part of fix for bz# 1456231 & 1196020, GB_GLFS_LRU_COUNT value which is defined in /etc/sysconfig/gluster-block file is set to a default value of 5. This means 5+1 block-hosting volumes can be created safely without hitting 1456231 & 1196020. If more volumes needs to be created, this configuration value has to be changed. As the file resides in the container, restart of container resets the file and any configuration changes made to it.

Either the configuration file has to be put elsewhere? (I'm not sure if that's a right way) or we have to persist this file.

Version-Release number of selected component (if applicable):
cns-deploy-5.0.0-12.el7rhgs.x86_64
Comment 2 Humble Chirammal 2017-08-29 07:29:14 EDT
With this configuration we can support "3.5T" disk space for gluster block volumes without any change. The customer may create different size of volumes in their setup, ideally it should be good enough, but if we need more volumes then we will in trouble. So for safer side, we need to take this bug for cns.
Comment 3 Humble Chirammal 2017-08-31 03:47:05 EDT
(In reply to Humble Chirammal from comment #2)
> With this configuration we can support "3.5T" disk space for gluster block
> volumes without any change. The customer may create different size of
> volumes in their setup, ideally it should be good enough, but if we need
> more volumes then we will in trouble. So for safer side, we need to take
> this bug for cns.

As per discussion in #cns chat, we need to pass a higher count of this VARIABLE to the gluster-block executable.
Comment 6 Saravanakumar 2017-09-01 04:33:39 EDT
GB_GLFS_LRU_COUNT env. variable added:
https://github.com/gluster/gluster-kubernetes/pull/335
Comment 8 krishnaram Karthick 2017-09-11 22:44:30 EDT
GB_GLFS_LRU_COUNT value is now set in build - cns-deploy-5.0.0-34.el7rhgs.x86_64

[root@dhcp46-207 ~]# oc rsh glusterfs-jp160
sh-4.2# 
sh-4.2# 
sh-4.2# echo $GB_GLFS_LRU_COUNT
15

Moving the bug to verified.
Comment 10 errata-xmlrpc 2017-10-11 03:12:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2881

Note You need to log in before you can comment on or make changes to this bug.