Bug 14781 - Broken pipe
Broken pipe
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-28 02:20 EDT by paulh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 21:55:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description paulh 2000-07-28 02:20:05 EDT
Since RH 4, we have been plagued by an errors usually from the shell :

      Cannot reopen pipe

and the shell script fails. Netscape sometimes also fails to start with
error about a broken pipe. I am unable to find any reference to similar
problems in the various online resources. Also, this seems to occur at
random on a variety of machines ranging from Embedded motherboards to
733MHz PIII under a variety of loads.

I need some assistance on where to look in the kernel sources to track this
problem.
Comment 1 Erling Jacobsen 2001-10-25 17:53:31 EDT
See bug 8266 for more information and a possible work-around patch for bash.
Comment 2 paulh 2001-10-26 02:10:46 EDT
THis error has disappeared since RedHat 7.0 on my nightly builds.
Maybe this bug should be closed
Comment 3 Erling Jacobsen 2001-10-27 06:49:17 EDT
The bug should not be closed, as it hasn't been fixed in RHL 6.2.
The reason it appears fixed in RHL 7.x is (I think) that these systems
use bash2 as the default shell. If bash1 is still included in these
systems, it probably still has this bug. Anyway, even if the bug should be
fixed in RHL 7.x's bash1, it should also be fixed in RHL 6.2, as RH still
support that release.
Comment 4 dnd 2002-07-10 15:58:52 EDT
Hi Red Hat Support,

I have a customer on RHL6.2 and experiencing the report problem with bash as 
follows "Can't reopen pipe to command substitution" and when can I expect this 
to be fixed in RHL6.2?? 
If no fix then what suggestions do I provide to my customer??

DD.
Comment 5 Tim Waugh 2002-10-11 06:49:10 EDT
(This is not Red Hat Support.) 
 
This bug is fixed in the current release; closing.

Note You need to log in before you can comment on or make changes to this bug.