Bug 1478113 - duplicate status messages when saving automate methods
duplicate status messages when saving automate methods
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.9.0
Assigned To: Greg Piatigorski
Dmitry Misharov
: TestOnly, ZStream
Depends On:
Blocks: 1481442
  Show dependency treegraph
 
Reported: 2017-08-03 11:25 EDT by Jeffrey Cutter
Modified: 2018-05-29 04:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1481442 (view as bug list)
Environment:
Last Closed: 2018-03-06 09:56:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
duplicate saved statuses (27.49 KB, image/png)
2017-08-03 11:25 EDT, Jeffrey Cutter
no flags Details
duplicate notifications (311.13 KB, image/png)
2017-08-03 12:29 EDT, Jeffrey Cutter
no flags Details

  None (edit)
Description Jeffrey Cutter 2017-08-03 11:25:18 EDT
Created attachment 1308771 [details]
duplicate saved statuses

Description of problem:

See attached photo.  Status that automate method was saved presented multiple times.  We've also seen similar happen with Notifications from the notification pane duplicate all the way down the screen.

We've seen it happen on Chrome on Mac and Windows.
Comment 2 Jeffrey Cutter 2017-08-03 12:29:14 EDT
We were able to capture the duplicate notifications.  Will attach.
Comment 3 Jeffrey Cutter 2017-08-03 12:29 EDT
Created attachment 1308791 [details]
duplicate notifications
Comment 4 Dave Johnson 2017-08-03 19:50:42 EDT
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set it to Low/Low.
Comment 6 CFME Bot 2017-08-14 13:38:31 EDT
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/4cbb8ac52197b7b6b766640e3884f9429189d202

commit 4cbb8ac52197b7b6b766640e3884f9429189d202
Author:     Greg Piatigorski <gpiatigo@gmail.com>
AuthorDate: Mon Aug 7 22:37:14 2017 -0700
Commit:     Greg Piatigorski <gpiatigo@gmail.com>
CommitDate: Wed Aug 9 13:19:13 2017 -0700

    Delete duplicate flash message for Save, Reset and Cancel actions when editing Automation Method
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1478113

 app/views/miq_ae_class/_method_inputs.html.haml | 2 --
 1 file changed, 2 deletions(-)
Comment 8 Milan Falešník 2017-08-15 05:30:15 EDT
This is a duplicate of BZ#1437395
Comment 9 CFME Bot 2017-08-16 16:08:48 EDT
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/0fae15264a97ec16e57c8987e466e1fcfe876e8e

commit 0fae15264a97ec16e57c8987e466e1fcfe876e8e
Author:     Greg Piatigorski <gpiatigo@gmail.com>
AuthorDate: Mon Aug 7 22:37:14 2017 -0700
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed Aug 16 20:39:46 2017 +0200

    Delete duplicate flash message for Save, Reset and Cancel actions when editing Automation Method
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1478113

 app/views/miq_ae_class/_method_inputs.html.haml | 2 --
 1 file changed, 2 deletions(-)
Comment 10 Milan Falešník 2017-10-11 05:48:21 EDT
Verified in 5.9.0.1

Note You need to log in before you can comment on or make changes to this bug.