This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1478115 - [abrt] dnf: _hcmd_undo(): __init__.py:888:_hcmd_undo:IndexError: list index out of range
[abrt] dnf: _hcmd_undo(): __init__.py:888:_hcmd_undo:IndexError: list index o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Rohel
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4225ede4d943d60e97c50020907...
: Triaged
: 1473932 1490537 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 11:30 EDT by tpypta
Modified: 2017-10-04 18:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-2.7.2-1.fc27 dnf-2.7.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-04 10:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (429.45 KB, text/plain)
2017-08-03 11:30 EDT, tpypta
no flags Details
File: backtrace (1.14 KB, text/plain)
2017-08-03 11:30 EDT, tpypta
no flags Details
File: cgroup (355 bytes, text/plain)
2017-08-03 11:30 EDT, tpypta
no flags Details
File: cpuinfo (1.15 KB, text/plain)
2017-08-03 11:30 EDT, tpypta
no flags Details
File: dnf-makecache.log (295 bytes, text/plain)
2017-08-03 11:31 EDT, tpypta
no flags Details
File: environ (2.23 KB, text/plain)
2017-08-03 11:31 EDT, tpypta
no flags Details
File: mountinfo (3.58 KB, text/plain)
2017-08-03 11:31 EDT, tpypta
no flags Details
File: namespaces (102 bytes, text/plain)
2017-08-03 11:31 EDT, tpypta
no flags Details
File: open_fds (1.81 KB, text/plain)
2017-08-03 11:31 EDT, tpypta
no flags Details

  None (edit)
Description tpypta 2017-08-03 11:30:46 EDT
Version-Release number of selected component:
dnf-2.6.2-1.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/libexec/system-python /bin/dnf history undo 122-126
crash_function: _hcmd_undo
exception_type: IndexError
executable:     /bin/dnf
kernel:         4.11.11-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
__init__.py:888:_hcmd_undo:IndexError: list index out of range

Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1029, in run
    return self.command.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/__init__.py", line 944, in run
    ret = self._hcmd_undo(extcmds)
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/__init__.py", line 888, in _hcmd_undo
    return self.base.history_undo_transaction(extcmds[0])
IndexError: list index out of range

Local variables in innermost frame:
extcmds: []
self: <dnf.cli.commands.HistoryCommand object at 0x7f7ef93f56d8>
Comment 1 tpypta 2017-08-03 11:30:54 EDT
Created attachment 1308772 [details]
File: _var_log_dnf.log
Comment 2 tpypta 2017-08-03 11:30:55 EDT
Created attachment 1308773 [details]
File: backtrace
Comment 3 tpypta 2017-08-03 11:30:57 EDT
Created attachment 1308774 [details]
File: cgroup
Comment 4 tpypta 2017-08-03 11:30:58 EDT
Created attachment 1308775 [details]
File: cpuinfo
Comment 5 tpypta 2017-08-03 11:31:00 EDT
Created attachment 1308776 [details]
File: dnf-makecache.log
Comment 6 tpypta 2017-08-03 11:31:01 EDT
Created attachment 1308777 [details]
File: environ
Comment 7 tpypta 2017-08-03 11:31:03 EDT
Created attachment 1308778 [details]
File: mountinfo
Comment 8 tpypta 2017-08-03 11:31:05 EDT
Created attachment 1308779 [details]
File: namespaces
Comment 9 tpypta 2017-08-03 11:31:06 EDT
Created attachment 1308780 [details]
File: open_fds
Comment 10 Jaroslav Rohel 2017-08-07 09:11:27 EDT
cmdline:        /usr/libexec/system-python /bin/dnf history undo 122-126

1. "122..126" is right syntax for transaction ID range definition
2. "undo" command can be called only for one transaction ID

I will prepare patch with better error handling.
Comment 11 Jaroslav Rohel 2017-08-08 07:59:27 EDT
Fixed in PR: https://github.com/rpm-software-management/dnf/pull/886
Comment 12 Jaroslav Rohel 2017-08-11 06:07:05 EDT
*** Bug 1473932 has been marked as a duplicate of this bug. ***
Comment 13 Jaroslav Rohel 2017-09-15 06:37:39 EDT
*** Bug 1490537 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2017-10-02 06:34:22 EDT
dnf-plugins-extras-2.0.3-1.fc27 dnf-plugins-core-2.1.4-1.fc27 dnf-2.7.2-1.fc27 libdnf-0.10.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683
Comment 15 Fedora Update System 2017-10-02 06:37:52 EDT
dnf-plugins-extras-2.0.3-1.fc26 dnf-plugins-core-2.1.4-1.fc26 dnf-2.7.2-1.fc26 libdnf-0.10.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065
Comment 16 Fedora Update System 2017-10-02 16:28:35 EDT
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-70a8618065
Comment 17 Fedora Update System 2017-10-02 17:27:50 EDT
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-faf235c683
Comment 18 Fedora Update System 2017-10-04 10:23:28 EDT
dnf-2.7.2-1.fc27, dnf-plugins-core-2.1.4-1.fc27, dnf-plugins-extras-2.0.3-1.fc27, libdnf-0.10.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2017-10-04 18:25:31 EDT
dnf-2.7.2-1.fc26, dnf-plugins-core-2.1.4-1.fc26, dnf-plugins-extras-2.0.3-1.fc26, libdnf-0.10.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.