Bug 1478131 - qt5-qtwebkit package dependencies broken after RHEL 7.4 update
qt5-qtwebkit package dependencies broken after RHEL 7.4 update
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: qt5-qtwebkit (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 1481792 1488362 1489522 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 12:08 EDT by Victor Schulz
Modified: 2017-09-14 03:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: qt5-qtwebkit-5.6.2-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-31 11:19:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'yum install qt5-qtwebkit' (3.21 KB, text/plain)
2017-08-03 12:08 EDT, Victor Schulz
no flags Details

  None (edit)
Description Victor Schulz 2017-08-03 12:08:08 EDT
Created attachment 1308788 [details]
Output of 'yum install qt5-qtwebkit'

Description of problem:
When trying to install the qt5-qtwebkit package (in my particular case as a dependency of the nextcloud-client package), there are broken dependencies. As far as I can tell, this is related to the now available qt5 packages on the rhel-7-server-rpms repository, which are newer than what the qt5-qtwebkit package in epel expects.

Version-Release number of selected component (if applicable):
qt5-qtwebkit-5.6.1-3.b889f46git.el7.x86_64

How reproducible:
The bug affects Red Hat Enterprise Linux Server release 7.4 (Maipo)
Current CentOS (7.3.1611) is not affected due to the 7.4 packages have not reached yet the repositories.

Steps to Reproduce:
1. Simply running 'yum install qt5-qtwebkit' is enough.

Actual results:
Current qt5-qtwebkit requires 'qt5-qtbase(x86-64) = 5.6.1' and 'qt5-qtdeclarative(x86-64) = 5.6.1' but the version installed on the system is qt5-qtbase-5.6.2-1.el7.x86_64 and qt5-qtdeclarative-5.6.2-1.el7.x86_64.

Expected results:
qt5-qtwebkit has no broken dependencies an can be installed.

Additional info:
Attached is the yum command output.
Comment 1 Rex Dieter 2017-08-04 10:23:41 EDT
Looks like epel buildroots still include qt5-qtbase-5.7.1 as of today.  We'll have to wait for that before this can be fixed.
Comment 2 Rex Dieter 2017-08-04 10:23:54 EDT
sorry, make that 5.6.1
Comment 3 Victor Schulz 2017-08-04 13:45:36 EDT
Thanks for looking into it.

As a workaround, I was able to downgrade the qt5 packages to the versions available on EPEL, and installed the packages that depend on them with the rhel-7-server-rpms repository temporarily disabled. I'll be holding the update of these packages until this can be fixed.
Comment 4 Oliver Haessler 2017-08-10 03:56:09 EDT
This bug also prevents a successful upgrade from RHEL 7.3 to 7.4, as the qt5-qtwebkit package is expected to be version 5.6.2-1

A quick fix would be highly appreciated, as I am in the process to prepare the upgrade for ~3000 systems, and I have no idea how many users have qt5-qtwebkit installed.
Comment 5 Rex Dieter 2017-08-10 11:13:54 EDT
epel buildroots are not yet updated it seems :(

Latest attempt,
https://koji.fedoraproject.org/koji/taskinfo?taskID=21148998
Comment 6 Rex Dieter 2017-08-12 13:32:04 EDT
Currently blocking on,
https://pagure.io/releng/issue/6950
(pending next epel7 repo push, hopefully real soon now)
Comment 7 Fedora Update System 2017-08-14 22:24:31 EDT
qt5-qtquick1-5.6.2-1.64faeb0git.el7 qt5-qtquickcontrols2-5.6.2-1.el7 qt5-qtstyleplugins-5.0.0-15.el7 qt5-qtwebkit-5.6.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-41c6892a24
Comment 8 Rex Dieter 2017-08-15 15:35:03 EDT
*** Bug 1481792 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2017-08-15 17:50:41 EDT
qt5-qtquick1-5.6.2-1.64faeb0git.el7, qt5-qtquickcontrols2-5.6.2-1.el7, qt5-qtstyleplugins-5.0.0-15.el7, qt5-qtwebkit-5.6.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-41c6892a24
Comment 10 Victor Schulz 2017-08-16 15:07:55 EDT
I tried doing the update to the testing package, but now the qt-creator package is blocking the update, as it is still depends on qt5-qtbase 5.6.1, which is supposed to be updated to the 5.6.2 version.

I temporarily removed the qt-creator package to test the qt5-qtwebkit testing update and it installed correctly with no problems so far.

So, in short, qt-creator package should be also updated so that it is compatible with the new qt5-qtbase 5.6.2 package.
Comment 11 Rex Dieter 2017-08-16 15:30:35 EDT
See separate qt-creator update,
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-53bf9d8d3c
Comment 12 Rex Dieter 2017-08-16 15:31:18 EDT
and related bug #1481978
Comment 13 Victor Schulz 2017-08-19 01:07:12 EDT
I just installed the testing version of qt-creator, now everything is working. Thanks for the excellent work!
Comment 14 Fedora Update System 2017-08-31 11:19:11 EDT
qt5-qtquick1-5.6.2-1.64faeb0git.el7, qt5-qtquickcontrols2-5.6.2-1.el7, qt5-qtstyleplugins-5.0.0-15.el7, qt5-qtwebkit-5.6.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Rex Dieter 2017-09-05 08:09:44 EDT
*** Bug 1488362 has been marked as a duplicate of this bug. ***
Comment 16 Rex Dieter 2017-09-07 23:57:27 EDT
*** Bug 1489522 has been marked as a duplicate of this bug. ***
Comment 17 Daniel_Stm 2017-09-13 07:14:57 EDT
Altough I managed to install qt5-qtwebkit-5.6.2-1.el7 on CentOS7 now, I'm unable to achieve it on RHEL 7.3 and RHEL 7.4 (both recently set up just for testing this).

It misses several Qt dependencies, (libQt5{Qml,Quick,Positioning,WebChannel}).
Prominently, it misses qt5-qtdeclarative(x86_64) = 5.6.2.
Attempts to install qt5-qtdeclarative say it does not exist.
I have tried this over and over for weeks in the hope it is temporary.
yum --enablerepo="*" install qt5-qtdeclarative
=> No package qt5-qtdeclarative available

Should this package exist or is it provided by a different package? And in which repository should it be found?

I noticed that the desktop-extras repo contains zero packages, which I find odd.
I have had this consistently on both installations, no matter how often I clear/refresh the cache. I'd be thankful if somebody could point out whether this is
* normal/expected
* related to my issue (in the sense that it should contain the missing deps)
* a known issue
* if so, how to debug/resolve this

Output of yum repolist: (minus repo name colum)
repo id                                     status
epel/x86_64                                 11898
rhel-7-desktop-extras-rpms/x86_64               0
rhel-7-desktop-optional-rpms/7Client/x86_64 14435
rhel-7-desktop-rpms/7Client/x86_64          13789
repolist: 40122
Comment 18 Rex Dieter 2017-09-13 09:08:15 EDT
One rhel box I have access to at the moment includes qt5-qtdeclarative in rhel-7-server-rpms
Comment 19 Daniel_Stm 2017-09-14 03:59:30 EDT
Thanks a lot. I concluded and confirmed that qt5-qtwebkit can ultimately not be installed with a Desktop subscription, but Workstation and Server.

Note You need to log in before you can comment on or make changes to this bug.