Bug 1478136 - [GNFS] gnfs crashed at nfs3_lookup while subdir mount on solaris client
[GNFS] gnfs crashed at nfs3_lookup while subdir mount on solaris client
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nfs (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity urgent
: ---
: RHGS 3.3.0
Assigned To: Niels de Vos
Manisha Saini
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-08-03 12:35 EDT by Manisha Saini
Modified: 2017-09-21 01:04 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-38
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 01:04:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manisha Saini 2017-08-03 12:35:42 EDT
Description of problem:
gnfs crashed at nfs3_lookup while subdir mount on solaris client.

This bug is to track the backport of missing patch for bug-https://bugzilla.redhat.com/show_bug.cgi?id=1472773

Version-Release number of selected component (if applicable):
glusterfs-fuse-3.8.4-37.el7rhgs.x86_64

How reproducible:


Steps to Reproduce:
1.Create EC volume
2.Export the volume via GNFS
3.Mount the volume on solaris client
4.Create a directory on the mount point
5.Unmount the volume
6.Mount the subdir to the same solaris client.
7.Provide permission to export subdirectory mani to client 10.70.37.192 only (which is other client,not solaris client)

#gluster v set disperseVol nfs.export-dir "/subdir(10.70.37.192)"
volume set: success

# gluster v get disperseVol all | grep export
nfs.export-dirs                         on                                      
nfs.export-volumes                      on                                      
nfs.export-dir                          /subdir(10.70.37.192)                     
nfs.exports-auth-enable                 (null)           

Actual results:
GNFS got crashed at nfs3_lookup


[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `/usr/sbin/glusterfs -s localhost --volfile-id gluster/nfs -p /var/lib/glusterd/'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007f3bb4e1f215 in _gf_ref_put () from /lib64/libglusterfs.so.0
Missing separate debuginfos, use: debuginfo-install glusterfs-fuse-3.8.4-37.el7rhgs.x86_64
(gdb) bt
#0  0x00007f3bb4e1f215 in _gf_ref_put () from /lib64/libglusterfs.so.0
#1  0x00007f3ba6b24de2 in nfs3_lookup () from /usr/lib64/glusterfs/3.8.4/xlator/nfs/server.so
#2  0x00007f3ba6b25418 in nfs3svc_lookup () from /usr/lib64/glusterfs/3.8.4/xlator/nfs/server.so
#3  0x00007f3bb4b738c5 in rpcsvc_handle_rpc_call () from /lib64/libgfrpc.so.0
#4  0x00007f3bb4b73aab in rpcsvc_notify () from /lib64/libgfrpc.so.0
#5  0x00007f3bb4b759e3 in rpc_transport_notify () from /lib64/libgfrpc.so.0
#6  0x00007f3ba99a43d6 in socket_event_poll_in ()
   from /usr/lib64/glusterfs/3.8.4/rpc-transport/socket.so
#7  0x00007f3ba99a697c in socket_event_handler ()
   from /usr/lib64/glusterfs/3.8.4/rpc-transport/socket.so
#8  0x00007f3bb4e0b106 in event_dispatch_epoll_worker () from /lib64/libglusterfs.so.0
#9  0x00007f3bb3c0fe25 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f3bb34dc34d in clone () from /lib64/libc.so.6
(gdb) q


Expected results:
GNFS should not crash while mounting subdir to client

Additional info:
Hit this bug while verifying BZ -https://bugzilla.redhat.com/show_bug.cgi?id=1451224
Comment 2 Atin Mukherjee 2017-08-04 00:07:30 EDT
upstream patch : https://review.gluster.org/#/c/17822/
Comment 3 Atin Mukherjee 2017-08-04 02:39:50 EDT
patch is already present in 3.12.

downstream patch : https://code.engineering.redhat.com/gerrit/#/c/114348/
Comment 7 Manisha Saini 2017-08-05 14:48:56 EDT
Verified this bug on  glusterfs-3.8.4-38.el7rhgs.x86_64



Steps:
1.Create a 2 x (4 + 2) Distributed-Disperse Volume
2.Export the volume via GNFS
3.Mount the volume to solaris client.Create a sub dir inside the mount mount

-bash-3.00# mount -o proto=tcp,vers=3 nfs://10.70.42.1:/disperseVol
/mnt/GNFSMOunt/      
-bash-3.00# cd /mnt/GNFSMOunt/
l-bash-3.00# ls
msaini

4.Unmount the volume
5.Mount the subdir on solaris client created at step 3
-bash-3.00# mount -o proto=tcp,vers=3 nfs://10.70.42.1:/disperseVol/mani
/mnt/GNFSMOunt/

6.Unmount the subdir

-bash-3.00# umount /mnt/GNFSMOunt/

7.Restrict the volume to some IP other then solaris client IP

# gluster v set disperseVol nfs.export-dir "/mani(10.70.37.142)"
volume set: success

8.Now again try mounting the same subdir "mani" on solaris client.Mount fails
as the solaris client doesnot have permission to mount.



-bash-3.00# mount -o proto=tcp,vers=3 nfs://10.70.42.1:/disperseVol/mani
/mnt/GNFSMOunt/
nfs mount: 10.70.42.1: : RPC: Program not registered
nfs mount: retrying: /mnt/GNFSMOunt



Unable to hit the crash with the same steps mentioned in this bug. Moving this bug to verified state
Comment 9 errata-xmlrpc 2017-09-21 01:04:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.