Bug 1478141 - Anaconda gives a traceback if there is non-activated InfiniBand network device present during an attempt to install in text mode
Anaconda gives a traceback if there is non-activated InfiniBand network devic...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
All Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F27FinalFreezeException
  Show dependency treegraph
 
Reported: 2017-08-03 13:05 EDT by Doug Ledford
Modified: 2017-11-08 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-27.20.4-2 anaconda-27.20.4-4.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-08 17:10:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda traceback debug file (367.74 KB, text/plain)
2017-08-03 13:05 EDT, Doug Ledford
no flags Details

  None (edit)
Description Doug Ledford 2017-08-03 13:05:57 EDT
Created attachment 1308804 [details]
Anaconda traceback debug file

Description of problem:

If the machine in question has InfiniBand hardware installed, anaconda will load the ib_ipoib module, this will create an ib0 device (and possibly more ib devices depending on the number of interfaces present).  Anaconda will then give a traceback and fail to install due to a SettingsNotFoundError('ib0',) in the pyanaconda.nm code.

Version-Release number of selected component (if applicable):

Latest Fedora 26 RC as well as current rawhide

How reproducible:

100%

Steps to Reproduce:
1. Attempt to install on machine with InfiniBand hardware
2. ?
3. Boom

Actual results:

Boom.

Expected results:

Install.

Additional info:

Traceback:

Starting installer, one moment...
anaconda 27.19-1 for Fedora Rawhide (pre-release) started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * if the graphical installation interface fails to start, try again with the
   inst.text bootoption to start text installation
 * when reporting a bug add logs from /tmp as separate text/plain attachments
16:56:15 Running pre-installation scripts
16:56:15 Running pre-installation scripts
+ command -v curl
                 + curl --help
                              + grep -q '.*--retry'
                                                   16:56:16 Not asking for VNC because of an automated install
16:56:16 Not asking for VNC because of an automated install
16:56:16 Not asking for VNC because text mode was explicitly asked for in kickstart
16:56:16 Not asking for VNC because text mode was explicitly asked for in kickstart

An unknown error has occured, look at the /tmp/anaconda-tb* file(s) for more details

=============================================================================== 
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/nm.py", line 799, in nm_device_setting_value
    raise SettingsNotFoundError(name)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/tui/spokes/network.py", line 84, in _load_new_devices
    if nm.nm_device_setting_value(name, "connection", "slave-type"):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/tui/spokes/network.py", line 63, in initialize
    self._load_new_devices()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/tui/hubs/__init__.py", line 70, in setup
    spoke.initialize()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 49, in setup
    should_schedule = TUIHub.setup(self, environment=environment)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/tui/__init__.py", line 182, in setup
    should_schedule = obj.setup(self.ENVIRONMENT)
  File "/sbin/anaconda", line 729, in <module>
    anaconda._intf.setup(ksdata)
pyanaconda.nm.SettingsNotFoundError: SettingsNotFoundError('ib0',)

What do you want to do now?
1) Report Bug
2) Debug
3) Run shell
4) Quit

Please make your choice from above:
Comment 1 Radek Vykydal 2017-10-13 09:03:24 EDT
Doug, could I have some beaker machine loaned to debug?
I used to use rdma-dev-10.lab.bos.redhat.com for development some time ago.
Comment 2 Radek Vykydal 2017-10-17 10:50:51 EDT
(In reply to Radek Vykydal from comment #1)
> Doug, could I have some beaker machine loaned to debug?
> I used to use rdma-dev-10.lab.bos.redhat.com for development some time ago.

I was able to borrow it today.
Comment 3 Radek Vykydal 2017-10-18 04:37:17 EDT
The crash occurs in text mode in case there is any Infiniband device that has not been activated by boot options or kickstart.
Comment 4 Radek Vykydal 2017-10-18 04:42:04 EDT
https://github.com/rhinstaller/anaconda/pull/1221
Comment 5 Fedora Blocker Bugs Application 2017-10-19 11:08:02 EDT
Proposed as a Freeze Exception for 27-final by Fedora user rvykydal using the blocker tracking app because:

 The bug prevents text (also automated text) installations on machines with infiniband device in cases where there is any infiniband device that has  not been activated by boot options or kickstart.
The issue is there since F26, it would be nice to have it fixed.
Comment 6 Geoffrey Marr 2017-10-23 17:44:43 EDT
Discussed during the 2017-10-23 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made as it can't be fixed by an update and will inconvenience anyone who runs into it.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-23/f27-blocker-review.2017-10-23-16.00.txt
Comment 7 Fedora Update System 2017-10-26 13:00:53 EDT
anaconda-27.20.4-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f
Comment 8 Fedora Update System 2017-10-27 14:49:22 EDT
anaconda-27.20.4-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f
Comment 9 Fedora Update System 2017-10-30 11:58:36 EDT
anaconda-27.20.4-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f
Comment 10 Fedora Update System 2017-10-31 15:09:18 EDT
anaconda-27.20.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f
Comment 11 Fedora Update System 2017-11-02 16:50:26 EDT
anaconda-27.20.4-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f
Comment 12 Fedora Update System 2017-11-04 14:01:09 EDT
anaconda-27.20.4-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f
Comment 13 Fedora Update System 2017-11-08 17:10:03 EST
anaconda-27.20.4-4.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.