Bug 1478198 - Install CNS failed due to cannot transfer an none regular file
Install CNS failed due to cannot transfer an none regular file
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 17:14 EDT by Wenkai Shi
Modified: 2017-08-16 15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenkai Shi 2017-08-03 17:14:39 EDT
Description of problem:
Install CNS failed due to cannot transfer an none regular file in task "Copy heketi private key", this task should only happened when customer use the "openshift_storage_glusterfs_heketi_ssh_keyfile" parameter. Seems this because of fix BZ #1477718 .

Version-Release number of the following components:
openshift-ansible-3.6.173.0.5-1.git.0.74d5acc.el7

How reproducible:
100%

Steps to Reproduce:
1. Install OCP with CNS
# cat hosts
[OSEv3:children]
masters
nodes
glusterfs

[OSEv3:vars]
...

[masters]
master-1.example.com

[nodes]
master-1.example.com
node-1.example.com
glusterfs-1.example.com 
glusterfs-2.example.com 
glusterfs-3.example.com 

[glusterfs]
glusterfs-1.example.com glusterfs_devices="['/dev/vsda']"
glusterfs-2.example.com glusterfs_devices="['/dev/vsda']"
glusterfs-3.example.com glusterfs_devices="['/dev/vsda']"

2.
3.

Actual results:
# ansible-playbook -i hosts -v /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml
...

TASK [openshift_storage_glusterfs : Copy heketi private key] *******************
Thursday 03 August 2017  19:16:42 +0000 (0:00:00.060)       0:13:35.782 ******* 
 [WARNING]: sftp transfer mechanism failed on
[master-1.example.com]. Use ANSIBLE_DEBUG=1 to see
detailed information

 [WARNING]: scp transfer mechanism failed on
[master-1.example.com]. Use ANSIBLE_DEBUG=1 to see
detailed information

fatal: [master-1.example.com]: FAILED! => {
    "failed": true
}

MSG:

failed to transfer file to /root/.ansible/tmp/ansible-tmp-1501787803.1-62624638446304/source:

/dev/null: not a regular file

Expected results:
This task should be skip when customer didn't use the "openshift_storage_glusterfs_heketi_ssh_keyfile" parameter.

Additional info:
Comment 5 Jose A. Rivera 2017-08-04 09:31:22 EDT
PR is upstream: https://github.com/openshift/openshift-ansible/pull/5000
Comment 8 Wenkai Shi 2017-08-05 00:35:35 EDT
Verified with version openshift-ansible-3.6.173.0.5-3.git.0.522a92a.el7, installation succeed.
Comment 10 errata-xmlrpc 2017-08-10 01:32:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.