Bug 1478250 - Idle nss file descriptors should be closed [rhel-7.4.z]
Idle nss file descriptors should be closed [rhel-7.4.z]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.4
All All
urgent Severity urgent
: rc
: ---
Assigned To: SSSD Maintainers
Amith
: Regression, ZStream
Depends On: 1464049
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-04 02:36 EDT by Oneata Mircea Teodor
Modified: 2017-09-05 07:24 EDT (History)
10 users (show)

See Also:
Fixed In Version: sssd-1.15.2-50.el7_4.2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1464049
Environment:
Last Closed: 2017-09-05 07:24:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oneata Mircea Teodor 2017-08-04 02:36:06 EDT
This bug has been copied from bug #1464049 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 4 Amith 2017-08-18 09:57:23 EDT
Verified the bug on SSSD Version: sssd-1.15.2-50.el7_4.2.x86_64

Steps followed during verification:

1. Setup sssd.conf as mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1464049#c0

2. login as ldap user in SSSD client machine and wait for over a minute.

3. Monitor NSS and PAM file descriptors on a different terminal.

With the latest sssd build, the count of FD's has come down to one. Earlier with old build we use to see more than 2 idle connections.

[root@idm-qe-01 ~]# lsof -p $(pidof sssd_nss) | grep /var/lib/sss/pipes/nss
sssd_nss 30620 root   17u     unix 0xffff8801fefcb400       0t0     56264 /var/lib/sss/pipes/nss
[root@idm-qe-01 ~]# 
[root@idm-qe-01 ~]# lsof -p $(pidof sssd_pam) | grep /var/lib/sss/pipes/pam
sssd_pam 30621 root    0u     unix 0xffff8800e0a16800       0t0     57000 /var/lib/sss/pipes/pam
[root@idm-qe-01 ~]# 
[root@idm-qe-01 ~]# lsof -p $(pidof sssd_nss) | grep /var/lib/sss/pipes/nss
sssd_nss 30620 root   17u     unix 0xffff8801fefcb400       0t0     56264 /var/lib/sss/pipes/nss
[root@idm-qe-01 ~]# 
[root@idm-qe-01 ~]# lsof -p $(pidof sssd_pam) | grep /var/lib/sss/pipes/pam
sssd_pam 30621 root    0u     unix 0xffff8800e0a16800       0t0     57000 /var/lib/sss/pipes/pam
Comment 6 errata-xmlrpc 2017-09-05 07:24:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2574

Note You need to log in before you can comment on or make changes to this bug.