This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 147828 - cman initscript in_cluster function needs rework after latest cman changes
cman initscript in_cluster function needs rework after latest cman changes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On: 149236
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 13:57 EST by Derek Anderson
Modified: 2009-04-24 10:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 10:32:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2005-02-11 13:57:29 EST
Description of problem:
The latest changes in cman regarding node naming have made it
necessary to change how the in_cluster() function works.  Currently it
looks for the node's shortname in /proc/cluster/nodes.  I was testing
private network stuff so had link-10-pvt in the cluster.conf.  They
joined just fine, but I was sitting around waiting 5 minutes for it to
fail because link-10-pvt != link-10.  I can't think of a clean way to
implement this check.  Hope someone can.

Version-Release number of selected component (if applicable):
cman-1.0-0.pre21.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Derek Anderson 2005-02-11 14:03:47 EST
Makes stopping a beeeyatch too.
Comment 2 Adam "mantis" Manthei 2005-02-11 15:05:51 EST
Well, I definately can't use uname or shortname now since Dave's
recent changes break cman's behavior, and I'm not about to implelement
any ip resolving hacks to determine hostname.  Thankfully, Patrick
added the wait feauture to the `cman_tool join` command, so we're not
totally hosed.  Another option would be to force cman_tool join to use
a predetermined string (such as "hostname" or "uname -n") instead of
allowing cman_tool to try to guess it's value.  That way the startup
script will know what to look for in /proc/cluster/nodes.

I saw something in one of Patrick's commits about `cman_tool leave` 
now having a wait option too.  I'll try to pull that into the init
script refresh as well.
Comment 3 Adam "mantis" Manthei 2005-02-18 18:34:43 EST
patrial fix has been checked in.  leaving this still assigned because
I think I need to use the wait option, but am not getting it to work
like I expect at the moment.
Comment 4 Christine Caulfield 2009-04-24 10:32:19 EDT
Closing because the current initscript has been in the packages for ages and no-one has complained ;-)

Note You need to log in before you can comment on or make changes to this bug.