Bug 1478363 - Remove Env file for Manila Generic via RHOSP director
Summary: Remove Env file for Manila Generic via RHOSP director
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: x86_64
OS: Linux
low
low
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Victoria Martinez de la Cruz
QA Contact: Dustin Schoenbrun
Don Domingo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-04 12:40 UTC by Omar Sattar
Modified: 2018-12-12 02:35 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:33:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1708680 None None None 2017-10-31 10:23:23 UTC
OpenStack gerrit 490974 None master: MERGED tripleo-heat-templates: Removes manila-generic-config from TripleO (I2e1db2bd614eae65e59712f50dc3391f16f6b388) 2018-03-29 16:01:24 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:45 UTC

Description Omar Sattar 2017-08-04 12:40:17 UTC
Description of problem:
Enabling disabled manila service end up with following error.

| resource_name          | AllNodesDeploySteps                                                                                                              |
| resource_status        | UPDATE_FAILED                                                                                                                    |
| resource_status_reason | resources.AllNodesDeploySteps: resources.ControllerDeployment_Step3: Error: resources[0]: Deployment to server failed:           |
|                        | deploy_status_code : Deployment exited with non-zero status code: 6


Version-Release number of selected component (if applicable):

RHOSP11


How reproducible:


Steps to Reproduce:
1.Install redhat openstack undercloud and overcloud.
2.Enable manila in /usr/share/openstack-tripleo-heat-templates/overcloud-resource-registry-puppet.j2.yaml
3.Deploy with openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/environments/manila-generic-config.yaml

Actual results:

Update _ FAILED

Expected results:


Additional info:

Comment 1 Tom Barron 2017-08-04 13:50:47 UTC
We don't support the manila "generic" driver in RHOSP and should not be carrying the manila-generic-config.yaml downstream.

Resolution of this BZ will be to remove any appearance of support by removing the env file and any associated doc in RHOS.

The generic driver uses a Service Virtual Machine which is a single point of failure in the data path and which is therefore not suitable for deployment in RHOSP where all services must be capable of HA.

Comment 2 Omar Sattar 2017-08-05 07:26:10 UTC
(In reply to Tom Barron from comment #1)
> We don't support the manila "generic" driver in RHOSP and should not be
> carrying the manila-generic-config.yaml downstream.
> 
> Resolution of this BZ will be to remove any appearance of support by
> removing the env file and any associated doc in RHOS.
> 
> The generic driver uses a Service Virtual Machine which is a single point of
> failure in the data path and which is therefore not suitable for deployment
> in RHOSP where all services must be capable of HA.

So i should remove all env files related to generic driver and should deploy this with CephFS backend with full 9 node HA deployment?

Comment 3 Tom Barron 2017-08-05 10:00:56 UTC
The generic driver env file was contributed by the community, not by Red Hat, it doesn't work any more (if it ever did), and it isn't supported by Red Hat.

Whether you deploy with HA or not is entirely your choice but all the services and backends we support need to be such that a customer *can* deploy them with HA.  So there is stuff in upstream OpenStack that isn't supported in the Red Hat Open Stack Platform distribution.

Currently the only Red Hat *certified* back end for manila is NetApp.  We are however working on getting an NFS front end onto the Ceph driver and fully supporting it (currently the Ceph driver is offered in "tech preview").

You or anyone else in the OpenStack community is welcome to work on that env file, get it to work, and contribute it back upstream.  It's just not something we plan to work on ourselves.

Comment 5 Tom Barron 2017-11-21 18:10:38 UTC
490974 has merged upstream

Comment 10 Dustin Schoenbrun 2018-05-23 19:30:07 UTC
Tested with 2018-05-21.2 with RPM openstack-tripleo-heat-templates-8.0.2-23.el7ost.noarch and the Generic Driver THT is no longer present. Marking as verified.

[stack@undercloud-0 environments]$ pwd
/usr/share/openstack-tripleo-heat-templates/environments
[stack@undercloud-0 environments]$ ls | grep manila
manila-cephfsganesha-config-docker.yaml
manila-cephfsnative-config-docker.yaml
manila-cephfsnative-config.yaml
manila-isilon-config.yaml
manila-netapp-config-docker.yaml
manila-netapp-config.yaml
manila-unity-config.yaml
manila-vmax-config.yaml
manila-vnx-config.yaml

Comment 12 errata-xmlrpc 2018-06-27 13:33:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.