Bug 14784 - Kudzu isn't locale aware even translations exists (from i18n robot)
Summary: Kudzu isn't locale aware even translations exists (from i18n robot)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-28 08:48 UTC by Milan Kerslager
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-28 09:29:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable locale translations (5 lines of code) (765 bytes, patch)
2000-07-28 08:50 UTC, Milan Kerslager
no flags Details | Diff

Description Milan Kerslager 2000-07-28 08:48:37 UTC
There are tree bugs:

1) locale isn't called at the begginnig of the program
2) variable CATALOGS in po/Makefile is commented out
3) SPEC file doesn't include .mo files in /usr/share/locale/*/*/*

Without this, traslator's work is for...

Patch for 1) and 2) [5 lines of code] submited below.

Comment 1 Milan Kerslager 2000-07-28 08:50:17 UTC
Created attachment 1636 [details]
Patch to enable locale translations (5 lines of code)

Comment 2 Milan Kerslager 2000-07-28 09:28:59 UTC
During startup there is no $LANG or some other variable so kudzu pop-up in
english language only. The safest way is to include '. /etc/profile.d/lang.sh'
at the begginnig of the /etc/init.d/kudzu script. This script (lang.sh) is safe
and do the 'export' stuff exactly only for the needed variables.

I do not recommned to set up locale variables to master script (eg.
/etc/rc.d/rc) because there may be some side effect... 



Comment 3 Bill Nottingham 2000-07-28 15:44:17 UTC
This will be fixed in kudzu-0.57-1. Thanks for the
patch!


Note You need to log in before you can comment on or make changes to this bug.