Bug 1478442 - Run Jobs with Future Execution is creating two jobs
Run Jobs with Future Execution is creating two jobs
Status: CLOSED DUPLICATE of bug 1473341
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Remote Execution (Show other bugs)
6.2.10
Unspecified Unspecified
unspecified Severity urgent (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
:
: 1491938 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-04 10:41 EDT by Curtis Matthews
Modified: 2017-09-20 14:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 14:07:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Curtis Matthews 2017-08-04 10:41:50 EDT
Description of problem:  When scheduling a job with future execution, two sub-tasks are being created.  Depending on the type of job, this can cause failures.


Version-Release number of selected component (if applicable): 6.2.10


How reproducible:  Can reproduce everytime via the UI or the API.


Steps to Reproduce:
1.  Run job with future execution.
2.  Upon completion, 2 sub-tasks are listed for the same command.
3.

Actual results:  Job is being executed twice.


Expected results:  Job should only be executed once.


Additional info:  Tested this in an environment with 6.2.9 and the problem doesn't exist.
Comment 2 Curtis Matthews 2017-08-04 11:25:20 EDT
Still pulling the requested logs, etc. but this may be a duplicate of bug 1473341 depending on the minor revision.
Comment 4 Curtis Matthews 2017-08-09 14:07:00 EDT
hotfix-1478886 has corrected this issue.
Comment 6 Ivan Necas 2017-09-15 08:43:36 EDT
*** Bug 1491938 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.