Bug 1478569 - grub2-tools-efi obsoletes grub2-tools which stops RHEL 7.3 and lower installations that have the optional repository available [NEEDINFO]
grub2-tools-efi obsoletes grub2-tools which stops RHEL 7.3 and lower installa...
Status: NEW
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grub2 (Show other bugs)
All Linux
urgent Severity urgent
: rc
: 7.4
Assigned To: Peter Jones
Release Test Team
: PrioBumpGSS, Regression
Depends On:
Blocks: 1420851
  Show dependency treegraph
Reported: 2017-08-04 15:57 EDT by jcastran
Modified: 2017-08-18 07:55 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dmoessne: needinfo? (pjones)
jstodola: needinfo? (lkocman)

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3140461 None None None 2017-08-09 02:45 EDT

  None (edit)
Description jcastran 2017-08-04 15:57:48 EDT
Description of problem:
When installing RHEL 7.3 or lower and the optional repository is available, the new grub2-tools-efi package becomes available. It requires grub2-tools (grub2-tools does not require grub2-tools-efi)

Version-Release number of selected component (if applicable):
RHEL 7.3 and lower
Fully sync'd (7Server or 7.4 releasever) optional repository

How reproducible:

Steps to Reproduce:
1. Host optional repo or repo with only grub2-tools-efi-2.02-0.64.el7.x86_64.rpm
2. Have RHEL 7.3 (or lower) install with the optional repo enabled 
     repo --name=grub2-tools-efi-repo --baseurl=file:///tmp/grub2-tools-efi-repo/
3. Start installation

Actual results:
Install stops at:
   grub2-tools-efi.02-0.64.el7.x86_64 requires grub2-common = 1:2.02-0.64.el7

Expected results:
Install does not try to obsolete grub2-tools with grub2-tools-efi

Additional info:
We have tested removing the defining "Obsoletes" from the packages and confirmed that this will resolve this issue.


Note You need to log in before you can comment on or make changes to this bug.