Bug 1478589 - [RFE] [6.3] Note About Virt-Who Must Come From Red Hat Satellite Tools Repository.
[RFE] [6.3] Note About Virt-Who Must Come From Red Hat Satellite Tools Reposi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Virtual Instances Guide (Show other bugs)
6.2.10
Unspecified Unspecified
low Severity low (vote)
: Beta
: 6.X
Assigned To: Michaela Slaninkova
Russell Dickenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-04 17:20 EDT by Bernie Hoefer
Modified: 2017-08-14 10:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 10:34:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernie Hoefer 2017-08-04 17:20:48 EDT
Document URL:
<https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html/virtual_instances_guide/prerequisites#installing_virt-who>


Section Number and Name:
4.5. Installing virt-who


Describe the issue:
The guide contains the following note:

  The virt-who package must be obtained from the
  Red Hat Satellite Tools repository as this provides
  the latest version.

This caused a customer confusion, as despite having both the rhel-7-server-rpms and rhel-7-server-satellite-tools-6.2-rpms repositories enabled, yum only showed the virt-who package from the rhel-7-server-rpms repository.  Example:


# yum info virt-who | grep -E ^Name\|^Version\|^Release\|^Repo
Name        : virt-who
Version     : 0.19
Release     : 2.el7sat
Repo        : rhel-7-server-rpms/7Server/x86_64


Once the customer was informed that when 2 repositories contain the same package at the same version & release level, yum (apparently) will use the 1st repository it found it in.  Yum will not mention the 2nd repository.  Disabling the rhel-7-server-rpms proves this to be true:


# yum --disablerepo rhel-7-server-rpms info virt-who | grep -E ^Name\|^Version\|^Release\|^Repo
Name        : virt-who
Version     : 0.19
Release     : 2.el7sat
Repo        : rhel-7-server-satellite-tools-6.2-rpms/x86_64



Suggestions for improvement:
Maybe change the note to read:
  To ensure one installs the latest virt-who package,
  enable the Red Hat Satellite Tools repository.  If both it
  and the Red Hat Enterprise Linux repository contain
  the latest package, yum may pull it from either.
Comment 1 Rich Jerrido 2017-08-06 21:51:09 EDT
It is NOT universally true that the version of virt-who provided in the Satellite tools channel is the newest. 

Which version of virt-who the users gets is dependent on 

- the RHEL release cadence. 
- whether or not a newer version is _required_ to be shipped in the Satellite tools repo. 


As a general rule, the only time a new version of virt-who is shipped in the Satellite tools repo is when there are a number of fixes or enhancements that Satellite requires that are needed in a quicket cadence than the RHEL release cycle (every 6-8 months). 

As this scenarios cannot be known in advance, the only sane course of action to tell the end user is

- on the system that runs virt-who, enable the Satellite Tools repo. 
- let yum pick _whichever_ package is the latest.
Comment 2 Andrew Dahms 2017-08-08 22:35:18 EDT
Assigning to Misha for review.

Misha - looks like we need to update the note in question to say that the virt-who package is available from either channel, and that the latest version, whichever repo it comes from, is the one that we should install.
Comment 6 Michaela Slaninkova 2017-08-14 10:36:19 EDT
Hello,

These changes are now live on the customer portal.

Note You need to log in before you can comment on or make changes to this bug.