Bug 1478599 - older versions of lvm do not support --reportformat=json [NEEDINFO]
older versions of lvm do not support --reportformat=json
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Volume (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: rc
: 3.0
Assigned To: Alfredo Deza
shylesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-04 19:02 EDT by Alfredo Deza
Modified: 2017-12-05 18:39 EST (History)
7 users (show)

See Also:
Fixed In Version: RHEL: ceph-12.2.0-1.el7cp Ubuntu: ceph_12.2.0-2redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-05 18:39:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kdreyer: needinfo? (ceph-qe-bugs)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ceph/ceph/pull/17097 None None None 2017-08-21 11:09 EDT
Github ceph/ceph/pull/17123 None None None 2017-08-21 19:21 EDT

  None (edit)
Description Alfredo Deza 2017-08-04 19:02:02 EDT
Description of problem: Older versions of lvm do not allow --reportformat flags which the ceph-volume lvm api uses.


How reproducible: On systems with older lvm versions like Xenial


Steps to Reproduce: Run `ceph-volume lvm prepare` in Xenial

Actual results:
> sudo vgs --reportformat=json
> vgs: unrecognized option '--reportformat=json'


Additional info: The use of JSON needs to be dropped, and parsing of the CLI output needs to be implemented in ceph_volume/devices/lvm/api.py

lvm allows filtering, ordering, and separator addition(s) so it is a matter of defining this correctly and then parsing the output.
Comment 2 Alfredo Deza 2017-08-21 16:53:53 EDT
Verified working on Xenial.

merged commit 60eb0e5 into master
Comment 3 Ken Dreyer (Red Hat) 2017-08-21 17:20:03 EDT
Would you please do the cherry-pick to luminous so it'll be in v12.2.0?
Comment 10 errata-xmlrpc 2017-12-05 18:39:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387

Note You need to log in before you can comment on or make changes to this bug.