Bug 147866 - haldaemon dies leaving no indication why
haldaemon dies leaving no indication why
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 16:57 EST by Tom Wood
Modified: 2013-03-05 22:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 13:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2005-02-11 16:57:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
haldaemon starts and immediately dies.

Version-Release number of selected component (if applicable):
hal-0.4.7-1.FC3

How reproducible:
Always

Steps to Reproduce:
1.service haldaemon start
2.
3.
  

Additional info:

[root@tux ~]# hald --daemon=no --verbose=yes
16:56:08.850 [I] hald.c:394: hal 0.4.7
16:56:08.851 [I] hald.c:398: Will not daemonize
16:56:08.851 [E] hald_dbus.c:1934: dbus_bus_get(): Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused
[root@tux ~]# cd /var/run/dbus
[root@tux dbus]# ls
system_bus_socket
[root@tux dbus]# ls -l system*
srwxrwxrwx  1 root root 0 Feb 11 15:38 system_bus_socket
Comment 1 Tom Wood 2005-02-12 16:12:38 EST
hal can't start because dbus-daemon didn't stay up.  Found a stale
/var/run/messagebus.pid file that prevented dbus from starting.  Removed the
file, started messagebus, and then started haldaemon.  Both seem fine now.  Will
test during reboot.

Seems that /etc/rc.d/init.d/messagebus could stand to look for and remove stale
pidfiles (being careful to differentiate between the system-wide and user
daemons) like more well-behaved members of the family...

Side note:  Why have RH taken to renaming the system services to something other
than the binaries.  Has the desktop application renaming craze struck the system
processes team as well?  Seems counterproductive to me.
Comment 2 Steve Bangert 2005-03-15 06:20:21 EST
David, I too have this condition, about 30 minutes to a hour after
boot HAL just dies, it's getting frustrating, is it possible these
symptoms are the result of the memory leak that you recently found and
posted a patch for? Any thoughts? Steve
Comment 3 David Zeuthen 2005-03-21 13:07:25 EST
The symtoms described in comment 1 seems to be a D-BUS bug, not a hal bug.

Steve, about comment 2, I'm not sure why the hal daemon would die after 30
minutes. If you can reproduce this please open a new bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.