Bug 1478708 - [Cloud init] Failed to set hostname
[Cloud init] Failed to set hostname
Status: CLOSED DUPLICATE of bug 1450521
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cloud-init (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Israel Pinto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-06 07:34 EDT by Israel Pinto
Modified: 2017-11-07 10:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-07 10:05:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cloud-init.log (9.12 KB, application/x-xz)
2017-08-06 07:34 EDT, Israel Pinto
no flags Details

  None (edit)
Description Israel Pinto 2017-08-06 07:34:13 EDT
Created attachment 1309647 [details]
cloud-init.log

Description of problem:
Hostname is not set via rhevm cloud init. 


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.4 (Maipo)
#uname -a:
Linux dhcp163-94.scl.lab.tlv.redhat.com 3.10.0-693.el7.x86_64 #1 SMP Thu Jul 6 19:56:57 EDT 2017 x86_64 x86_64 x86_64 GNU/Linux
cloud init: cloud-init-0.7.9-9.el7.x86_64
RHVM:  4.1.5.1-0.1.el7
vdsm: vdsm-4.19.26-1.el7ev.x86_64


How reproducible:
all the time

Steps to Reproduce:
1. Create VM from rhel-guest-image with cloud init via rhevm.
2. Set hostname: cloud-init-test, user: root, password: 1, timezone: Pacific/Tongatapu 
3. Start VM

Actual results:
Hostname did not set.

Expected results:
Host name is set to FQDN 

Additional info:
payload on host:
{
  "availability_zone" : "nova",
  "hostname" : "cloud_init_test",
  "launch_index" : "0",
  "meta" : {
    "role" : "server",
    "dsmode" : "local",
    "essential" : "false"
  },
  "name" : "cloud_init_test",
  "uuid" : "ce251ba6-fe38-422f-b0d5-64b69072279a"
}#cloud-config
output:
  all: '>> /var/log/cloud-init-output.log'
password: '1'
disable_root: 0
runcmd:
- 'sed -i ''/^datasource_list: /d'' /etc/cloud/cloud.cfg; echo ''datasource_list:
  ["NoCloud", "ConfigDrive"]'' >> /etc/cloud/cloud.cfg'
timezone: Pacific/Tongatapu
ssh_pwauth: true
chpasswd:
  expire: false
user: root
Comment 2 Israel Pinto 2017-11-07 10:05:15 EST
Duplicate BZ of: 1450521

*** This bug has been marked as a duplicate of bug 1450521 ***

Note You need to log in before you can comment on or make changes to this bug.