Bug 1478715 - The engine fails to stop VM correctly
The engine fails to stop VM correctly
Status: CLOSED DUPLICATE of bug 1478712
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.20.0
x86_64 Linux
unspecified Severity high (vote)
: ---
: ---
Assigned To: Dan Kenigsberg
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-06 08:51 EDT by Artyom
Modified: 2017-08-09 03:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 03:41:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm and engine logs (5.10 MB, application/zip)
2017-08-06 08:51 EDT, Artyom
no flags Details

  None (edit)
Description Artyom 2017-08-06 08:51:46 EDT
Created attachment 1309651 [details]
vdsm and engine logs

Description of problem:
Sometimes the engine fails to power-off VM correctly and throws GeneralException
2017-08-03 04:21:48,487+03 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (default task-15) [vms_syncAction_7a447acd-2ddf-4325] Command 'DestroyVDSCommand(HostName = host_mixed_3, DestroyVmVDSCommandParameters:{hostId='1bf34acd-12cb-4cfe-8d24-563c4079c3ba', vmId='2c4820fb-0b87-45d5-8df6-61dc4d45703f', secondsToWait='0', gracefully='false', reason='', ignoreNoVm='false'})' execution failed: VDSGenericException: VDSErrorException: Failed to DestroyVDS, error = General Exception: ("VM '2c4820fb-0b87-45d5-8df6-61dc4d45703f' was not defined yet or was undefined",), code = 100
2017-08-03 04:21:48,487+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (default task-15) [vms_syncAction_7a447acd-2ddf-4325] FINISH, DestroyVDSCommand, log id: 5adc3649
2017-08-03 04:21:48,487+03 ERROR [org.ovirt.engine.core.vdsbroker.DestroyVmVDSCommand] (default task-15) [vms_syncAction_7a447acd-2ddf-4325] Failed to destroy VM '2c4820fb-0b87-45d5-8df6-61dc4d45703f' in VDS = '1bf34acd-12cb-4cfe-8d24-563c4079c3ba' , error = 'org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to DestroyVDS, error = General Exception: ("VM '2c4820fb-0b87-45d5-8df6-61dc4d45703f' was not defined yet or was undefined",), code = 100'
2017-08-03 04:21:48,487+03 INFO  [org.ovirt.engine.core.vdsbroker.DestroyVmVDSCommand] (default task-15) [vms_syncAction_7a447acd-2ddf-4325] FINISH, DestroyVmVDSCommand, log id: 510db81c
2017-08-03 04:21:48,488+03 ERROR [org.ovirt.engine.core.bll.StopVmCommand] (default task-15) [vms_syncAction_7a447acd-2ddf-4325] Command 'org.ovirt.engine.core.bll.StopVmCommand' failed: EngineException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to DestroyVDS, error = General Exception: ("VM '2c4820fb-0b87-45d5-8df6-61dc4d45703f' was not defined yet or was undefined",), code = 100 (Failed with error GeneralException and code 100)
2017-08-03 04:21:48,489+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (ForkJoinPool-1-worker-13) [] Failed to destroy VM '2c4820fb-0b87-45d5-8df6-61dc4d45703f' because VM does not exist, ignoring
2017-08-03 04:21:48,489+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (ForkJoinPool-1-worker-13) [] FINISH, DestroyVDSCommand, log id: 7f098cf0
2017-08-03 04:21:48,489+03 INFO  [org.ovirt.engine.core.vdsbroker.monitoring.VmAnalyzer] (ForkJoinPool-1-worker-13) [] VM '2c4820fb-0b87-45d5-8df6-61dc4d45703f'(golden_env_mixed_virtio_1_1) was unexpectedly detected as 'Down' on VDS '1bf34acd-12cb-4cfe-8d24-563c4079c3ba'(host_mixed_3) (expected on '59b198c7-1d37-454e-a839-334cdcedb250')
2017-08-03 04:21:48,499+03 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-15) [vms_syncAction_7a447acd-2ddf-4325] EVENT_ID: USER_FAILED_STOP_VM(56), Failed to power off VM golden_env_mixed_virtio_1_1 (Host: host_mixed_1, User: admin@internal-authz).
2017-08-03 04:21:48,502+03 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (default task-15) [] Operation Failed: [General Exception]
2017-08-03 04:21:48,868+03 INFO  [org.ovirt.engine.core.bll.StopVmCommand] (default task-14) [vms_syncAction_1a9ee2b0-498b-4a41] Running command: StopVmCommand internal: false. Entities affected :  ID: fe16713b-7653-4f90-ac4d-a050a08d0d8b Type: VMAction group STOP_VM with role type USER
2017-08-03 04:21:48,874+03 INFO  [org.ovirt.engine.core.vdsbroker.DestroyVmVDSCommand] (default task-14) [vms_syncAction_1a9ee2b0-498b-4a41] START, DestroyVmVDSCommand( DestroyVmVDSCommandParameters:{hostId='59b198c7-1d37-454e-a839-334cdcedb250', vmId='fe16713b-7653-4f90-ac4d-a050a08d0d8b', secondsToWait='0', gracefully='false', reason='', ignoreNoVm='false'}), log id: 61a78371
2017-08-03 04:21:48,876+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (default task-14) [vms_syncAction_1a9ee2b0-498b-4a41] START, DestroyVDSCommand(HostName = host_mixed_1, DestroyVmVDSCommandParameters:{hostId='59b198c7-1d37-454e-a839-334cdcedb250', vmId='fe16713b-7653-4f90-ac4d-a050a08d0d8b', secondsToWait='0', gracefully='false', reason='', ignoreNoVm='false'}), log id: 2ec12218
2017-08-03 04:21:59,974+03 INFO  [org.ovirt.engine.core.vdsbroker.monitoring.VmAnalyzer] (ForkJoinPool-1-worker-13) [] VM 'fe16713b-7653-4f90-ac4d-a050a08d0d8b' was reported as Down on VDS '59b198c7-1d37-454e-a839-334cdcedb250'(host_mixed_1)
2017-08-03 04:21:59,976+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (ForkJoinPool-1-worker-13) [] START, DestroyVDSCommand(HostName = host_mixed_1, DestroyVmVDSCommandParameters:{hostId='59b198c7-1d37-454e-a839-334cdcedb250', vmId='fe16713b-7653-4f90-ac4d-a050a08d0d8b', secondsToWait='0', gracefully='false', reason='', ignoreNoVm='true'}), log id: 332485de
2017-08-03 04:21:59,992+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (default task-14) [vms_syncAction_1a9ee2b0-498b-4a41] FINISH, DestroyVDSCommand, log id: 2ec12218
2017-08-03 04:21:59,992+03 INFO  [org.ovirt.engine.core.vdsbroker.DestroyVmVDSCommand] (default task-14) [vms_syncAction_1a9ee2b0-498b-4a41] FINISH, DestroyVmVDSCommand, log id: 61a78371
2017-08-03 04:21:59,998+03 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-14) [vms_syncAction_1a9ee2b0-498b-4a41] EVENT_ID: USER_STOP_VM(33), VM golden_env_mixed_virtio_1_0 powered off by admin@internal-authz (Host: host_mixed_1).
2017-08-03 04:22:00,033+03 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (ForkJoinPool-1-worker-13) [] Failed to destroy VM 'fe16713b-7653-4f90-ac4d-a050a08d0d8b' because VM does not exist, ignoring



Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170801132145.git3e12cf0.el7.centos.noarch
vdsm-4.20.2-2.git7ba8928.el7.centos.x86_64

How reproducible:
5%

Steps to Reproduce:
1. Start the VM
2. Power-off the VM
3.

Actual results:
The engine throws GeneralException error

Expected results:
VM must be destroyed correctly

Additional info:
I can not reproduce it manually, but it happens during our automation tests(in the last run it happened twice, in different tests).
Comment 1 Tomas Jelinek 2017-08-09 03:41:39 EDT
seems like the same issue causing this than 1478712, marking as duplicate

*** This bug has been marked as a duplicate of bug 1478712 ***

Note You need to log in before you can comment on or make changes to this bug.