Bug 1478724 - SELinux is preventing abrt-action-gen from 'read' accesses on the file gameoverlayrenderer.so.
SELinux is preventing abrt-action-gen from 'read' accesses on the file gameov...
Status: CLOSED DUPLICATE of bug 1524166
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2017-08-06 11:46 EDT by Jan Vlug
Modified: 2017-12-12 07:39 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-12-12 07:39:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan Vlug 2017-08-06 11:46:17 EDT
Description of problem:
SELinux is preventing abrt-action-gen from 'read' accesses on the file gameoverlayrenderer.so.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-action-gen should be allowed read access on the gameoverlayrenderer.so file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# ausearch -c 'abrt-action-gen' --raw | audit2allow -M my-abrtactiongen
# semodule -X 300 -i my-abrtactiongen.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:home_root_t:s0
Target Objects                gameoverlayrenderer.so [ file ]
Source                        abrt-action-gen
Source Path                   abrt-action-gen
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-260.3.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.11-300.fc26.x86_64 #1 SMP Mon
                              Jul 17 16:32:11 UTC 2017 x86_64 x86_64
Alert Count                   36
First Seen                    2017-08-06 16:18:06 CEST
Last Seen                     2017-08-06 16:18:07 CEST
Local ID                      aad39d38-fd8b-4818-9601-67e148309d23

Raw Audit Messages
type=AVC msg=audit(1502029087.161:531): avc:  denied  { read } for  pid=2386 comm="eu-unstrip" name="gameoverlayrenderer.so" dev="dm-3" ino=21368088 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:home_root_t:s0 tclass=file permissive=0

Hash: abrt-action-gen,abrt_t,home_root_t,file,read

Version-Release number of selected component:

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.11-300.fc26.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2017-12-12 07:39:01 EST

*** This bug has been marked as a duplicate of bug 1524166 ***

Note You need to log in before you can comment on or make changes to this bug.