Bug 1478732 - Procedure to create new puppet environment
Procedure to create new puppet environment
Status: CLOSED DUPLICATE of bug 1478403
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Puppet Guide (Show other bugs)
6.2.10
All Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: satellite-doc-list
satellite-doc-list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-06 12:42 EDT by Alfredo Pizarro
Modified: 2017-08-06 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-06 12:47:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alfredo Pizarro 2017-08-06 12:42:52 EDT
Document URL: https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html-single/puppet_guide/

Section Number and Name: 3.7. Puppet Environments ->  Creating Puppet Environments within Red Hat Satellite 

Describe the issue: When the procedure is followed as is, an error will arise when trying to register a new server via boostrap.py with a host group associated to this new environment recently create.

Suggestions for improvement: I'm not sure if is it a bug or missing information, but when I tried to follow the documentation it did not work. Instead, had to create a new environment creating manually a directory under /etc/puppet/environments/ and the import it from the portal. Once performed this procedure, it worked.

Additional information: When creating a new puppet environment trough satellite portal, the registration of a new server associated to this new environment trough bootstrap.py  would try to retrieve the puppet CA certificate, querying an address like this:
https://server.fqdn/https:8140/new_environment_created/certificate/ca?fail_on_404=true 
When I followed the instructions from the manual, it failed with an error "Environment not found". 
So the procedure I followed to  fix the issue was:
- I created a new directory in satellite under /etc/puppet/environments/ with the name of the new environment.
- After that, I went to Configure -> Environments -> Import from satellite. 
-  I associated the host group to the new environment 
- I re-run  boostrap.py in the server and it got registered with no issues.
Regards,
Alfredo Pizarro.
Comment 1 Alfredo Pizarro 2017-08-06 12:47:34 EDT

*** This bug has been marked as a duplicate of bug 1478403 ***

Note You need to log in before you can comment on or make changes to this bug.