Bug 147884 - [RHEL3] emacs srpm doesn't build anymore (execshield)
[RHEL3] emacs srpm doesn't build anymore (execshield)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: emacs (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
Depends On:
Blocks: 156320
  Show dependency treegraph
 
Reported: 2005-02-11 20:24 EST by Zenon Panoussis
Modified: 2015-01-07 19:09 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2005-189
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 10:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2005-02-11 20:24:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
Building on a full AS3 U4 system:

Loading vc-hooks...
Loading ediff-hook...
((51648 . 15332) (8352 . 0) (511 . 56) 72613 134860 (14 . 9) (21 . 0) (7135 . 1433))
Finding pointers to doc strings...
Finding pointers to doc strings...done
Wrote /mnt/sdc1/3/BUILD/emacs-21.3/lib-src/fns-21.3.1.el
Dumping under names emacs and emacs-21.3.1
make[1]: *** [emacs] Segmentation fault
make[1]: *** Deleting file `emacs'
make[1]: Leaving directory `/mnt/sdc1/3/BUILD/emacs-21.3/src'
make: *** [src] Error 2
error: Bad exit status from /mnt/sdc1/tmp/rpm-tmp.97432 (%build)



Version-Release number of selected component (if applicable):
emacs-21.3-4.1

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild emacs-21.3-4.1.src.rpm
  

Additional info:
Comment 1 Jens Petersen 2005-02-14 02:58:57 EST
Hmmm, reproduced.
Comment 2 Jay Turner 2005-02-14 04:52:24 EST
Very strange indeed.  Reproduced on i386, but IA64 and x86_64 are just fine.
Comment 3 Jens Petersen 2005-02-14 21:27:44 EST
Yep, this is probably due to execshield being added to the kernel.

So one needs to build emacs with "setarch i386" for RHEL 3
now too.  This will get fixed in the next emacs update.
Comment 4 Jens Petersen 2005-02-14 21:34:32 EST
ie this bug 101818 for RHEL  3..
Comment 5 Zenon Panoussis 2005-02-14 22:04:47 EST
Ugh. Logically, using 'setarch i386' on an i386 system should make no
difference at all. Reality defies logic though, and the package does
build correctly with 'setarch i386 rpmbuild --rebuild
emacs-21.3-4.1.src.rpm'. Thank you for this. I guess the bug can be
closed with WORKAROUND_AVAILABLE ;)
Comment 6 Zenon Panoussis 2005-02-14 22:07:25 EST
BTW, could this apply to RHEL 4 too? Better fix it before it hits the
streets. 
Comment 7 Jens Petersen 2005-02-14 22:28:41 EST
Basically "setarch i386" disables the kernel VM extension that
breaks emacs dumping.

The workaround has already been in Fedora Core for a while
and is already in RHEL 4. :)

Thank you very much for reporting this issue.

[Leaving this open until the workaround has been built.]
Comment 14 Red Hat Bugzilla 2005-09-28 10:53:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-189.html

Note You need to log in before you can comment on or make changes to this bug.