Bug 1478879 - compatibility level upgrade fails with incorrect/insufficient error message
compatibility level upgrade fails with incorrect/insufficient error message
Status: CLOSED DUPLICATE of bug 1432127
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
4.2.0
x86_64 All
unspecified Severity high (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Israel Pinto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 08:28 EDT by Dafna Ron
Modified: 2017-08-09 04:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 04:09:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dron: planning_ack?
dron: devel_ack?
dron: testing_ack?


Attachments (Terms of Use)
logs and screenshots (2.93 MB, application/x-gzip)
2017-08-07 08:28 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2017-08-07 08:28:51 EDT
Created attachment 1310034 [details]
logs and screenshots

Description of problem:

I tried to change the compatibility level on our cluster from 4.0 to 4.1 and failed the following error message: 

Error while executing action: Update of cluster compatibility version failed because there are VMs/Templates [XXXXXXXlong list of vmsXXXXXXXXX] with incorrect configuration. To fix the issue, please go to each of them, edit and press OK. If the save does not pass, fix the dialog validation.

when you edit the vm and click ok the configuration is saved and no error appears. 

engine log shows the reason for failure is macspool in special properties: 

2017-08-07 14:44:17,395+03 WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-87) [2697f1d1] Validation of action 'UpdateVm' failed for user dron@redhat.com. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__VM,ACTION_TYPE_FAILED_INVAL
ID_CUSTOM_PROPERTIES_INVALID_KEYS,$MissingKeys macspoof


+ there is a spelling error in the word 'dialog'

Version-Release number of selected component (if applicable):

ovirt-engine-4.1.4.2-0.1.el7.noarch

How reproducible:

100% 

Steps to Reproduce:
1. create vms with custom property 'macspoof' 
2. upgrade rhv from 4.0 to 4.1.4
3. change cluster compatibility from 4.0 to 4.1 
4. after the error message is presented -> navigate to vms tab -> edit the vm -> press ok

Actual results:

There is no error message presented in the vm to suggest what is the configuration issue with the vm 

Expected results:

we should suggest to the user a way to solve this issue so either the cluster upgrade or the edit of the vm should suggest a problem with the cluster properties. 

Additional info:

attaching engine log and screenshots 

2017-08-07 14:44:17,395+03 WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (default task-87) [2697f1d1] Validation of action 'UpdateVm' failed for user dron@redhat.com. Reasons: VAR__ACTION__UPDATE,VAR__TYPE__VM,ACTION_TYPE_FAILED_INVAL
ID_CUSTOM_PROPERTIES_INVALID_KEYS,$MissingKeys macspoof
Comment 1 Tomas Jelinek 2017-08-08 11:29:50 EDT
@Dafna: so after you have updated the VM manually, was it's configuration correct? Because I have a suspicion that yes - it dropped the incorrect custom property.

During the update cluster, the detailed error messages are supposed to be in auditlog but unfortunately due to https://bugzilla.redhat.com/show_bug.cgi?id=1432127 they are not.
Comment 2 Dafna Ron 2017-08-09 04:01:37 EDT
After I pressed edit -> OK nothing was removed from the configuraion and I was still bocked from the upgrade. 
I had to manually remove the custom property in order to continue with the upgrade.
Comment 3 Tomas Jelinek 2017-08-09 04:09:30 EDT
right, because you were still in the old cluster. To simulate the error you would have to set the custom compatibility for the VM to the new one.

But anyway, the core problem here is that the audit log does not contain the error messages which is 1432127. Closing this as duplicate of that one.

*** This bug has been marked as a duplicate of bug 1432127 ***

Note You need to log in before you can comment on or make changes to this bug.