Bug 1478919 - Fluentd depending on Ruby from RHEL which is End-of-Life
Summary: Fluentd depending on Ruby from RHEL which is End-of-Life
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: All
OS: All
low
low
Target Milestone: ---
: 4.1.0
Assignee: Rich Megginson
QA Contact: Anping Li
URL:
Whiteboard:
Depends On: 1547179
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-07 13:39 UTC by Peter Portante
Modified: 2019-06-04 10:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Fluentd has too many ruby dependencies to rebuild as ruby 2.5 SCL rpms for rhel7. Consequence: We were stuck with old Fluentd and ruby on rhel7. Fix: Build Fluentd from gem files, and use the ruby 2.5 SCL. Result: We have a Fluentd image running the very latest Fluentd and using ruby 2.5.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC
Github openshift origin-aggregated-logging pull 786 None None None 2017-11-16 21:09:02 UTC

Description Peter Portante 2017-08-07 13:39:12 UTC
The fluentd images we ship depend on the Ruby from RHEL which is apparently 2.0.0-p648.  That version appears to be EOL: https://www.ruby-lang.org/en/news/2016/02/24/support-plan-of-ruby-2-0-0-and-2-1/

We should consider what it takes to move the logging images to a version that is not EOL.  There are other products, e.g. CloudForms, which are using versions of Ruby that are not EOL (2.2 and 2.3, currently, looking to drop 2.2 when 2.4 support is announced).

Comment 1 Rich Megginson 2017-08-07 13:40:42 UTC
We are going to have to switch to using ruby 2.3 or later from SCL when we move to fluentd 0.14.  In the meantime, I trust that the RHEL/ruby team will be supporting not only us by all of the other products, projects, and customers that are using the ruby provided by RHEL.

Comment 2 Peter Portante 2017-08-07 14:01:05 UTC
Can we discuss this more?

Comment 3 Peter Portante 2017-10-06 17:00:35 UTC
Recently heard that Rich build a fluentd image use s2i using Ruby 2.3.  I think Anton also was able to do the same thing.

Comment 4 Rich Megginson 2017-11-16 21:09:02 UTC
This isn't an s2i image - it's the centos-ruby-24 base image.

Comment 7 Rich Megginson 2018-01-04 03:08:42 UTC
3.10 at the earliest.  We are going to have to port all 90+ rubygem packages to be SCL enabled.

Comment 9 Rich Megginson 2018-02-21 14:26:16 UTC
--- Comment #2 from Vít Ondruch <vondruch@redhat.com> ---
Ruby 2.0 being part of RHEL7 is supported under the same conditions as RHEL7:

https://access.redhat.com/support/policy/updates/errata/

Comment 12 Rich Megginson 2019-03-05 14:15:43 UTC
OCP 4.0 uses Fluentd 1.x running on a ruby 2.5 SCL image.

Comment 14 Anping Li 2019-03-08 05:01:36 UTC
Move to verified as comment 12

Comment 17 errata-xmlrpc 2019-06-04 10:40:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.