Bug 1478937 - openshift-logging playbook does not set OAP_PUBLIC_MASTER_URL correctly
openshift-logging playbook does not set OAP_PUBLIC_MASTER_URL correctly
Status: CLOSED DUPLICATE of bug 1464349
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 10:30 EDT by Johan Swensson
Modified: 2017-08-08 02:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 02:12:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Swensson 2017-08-07 10:30:18 EDT
Description of problem:
OAP_PUBLIC_MASTER_URL is not correctly populated in a HA environment.

Version-Release number of the following components:
$ rpm -q openshift-ansible
openshift-ansible-3.5.101-1.git.0.0107544.el7.noarch

$ rpm -q ansible
ansible-2.3.1.0-3.el7.noarch

$ ansible --version
ansible 2.3.1.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = Default w/o overrides
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]

How reproducible:
Every time when running the openshift-logging playbook. It also get reset to the incorrect value when re-running the playbook.

Steps to Reproduce:
1. Set up a HA OCP cluster
2. Run the openshift-logging playbook


Actual results:
Kibana does not redirect to the correct master URL. Which will make logging in impossible since it redirects to the incorrect URL.

Expected results:
The URL that should be populated to this variable should probably be openshift_master_cluster_public_hostname instead of the first master that's being set in the kibana deploymentconfig.

Additional information:
This also goes for OAP_LOGOUT_REDIRECT.
This also happens with kibana-ops deployed.
Comment 1 Johan Swensson 2017-08-08 02:12:13 EDT

*** This bug has been marked as a duplicate of bug 1464349 ***

Note You need to log in before you can comment on or make changes to this bug.